MAME- add coin?

This may sound dumb but I cannot for the life of me figure out how to add a coin in the MAME core on Android (just the plain “MAME” core, not 2003, 2010, etc.). I have tried using the touch overlays, a real controller- I cannot find any menu option that allows me to map it. Nothing works. How do I do it? I have to use this core as the other MAME core options and FB Alpha don’t support a couple of games I want to play.

I don’t know if it is the same on the Android version, but usually coin is mapped to the select button.

Yeah it’s not working on either an Xbox One or PS4 controller, and there’s no coin function i can find to remap in any of the core or Retroarch options.

There are no core control options for MAME iirc. It has it’s own, internal options for that.

There should be a button that brings it’s internal menu that looks like this:


The coin/credit option is somewhere in the “input (general)”

Not sure what button calls this menu on Android though. I use it on Windows and if everything fails, i just press the TAB button on the keyboard.

By default, the credit/coin key should be the “select” button. Not sure why it isn’t working for you. Does it work in other cores? If no, check if the main RetroArch input options have the select button mapped somewhere. If yes, there must be a config file or line in the main config that messes up MAME’s config somewhere.

Tried everything, including breaking out to that menu by plugging in a freaking full-sized USB keyboard to my phone (the things we do for retro gaming). I can get to the menu and map the coin button but it just flat-out will not recognize a coin insertion. I’m pretty certain the core is just broken on this version.

Could be. Can’t test it though since i only use the Windows version.

Added an issue to the github. Found it is localized to certain games; sf2 works for example, but airco22b and tokyowar do not.

Did u also update the roms to mame 0.227?..ill test tonight with those games…I only use android so ill test it and check…maybe its a rom issue because like we saw in the github post select does work for coin on sf2