Mame core doesn't save anything from the TAB menu

When you load a game and press TAB, a menu comes up where you can change controls and other things. However, when i change something, it doesn’t save.

These are my core settings:

mame_alternate_renderer = “disabled” mame_altres = “640x480” mame_auto_save = “disabled” mame_boot_from_cli = “disabled” mame_boot_to_bios = “disabled” mame_boot_to_osd = “disabled” mame_buttons_profiles = “enabled” mame_cheats_enable = “enabled” mame_lightgun_mode = “none” mame_mame_paths_enable = “enabled” mame_media_type = “rom” mame_mouse_enable = “disabled” mame_read_config = “enabled” mame_saves = “game” mame_softlists_auto_media = “enabled” mame_softlists_enable = “enabled” mame_throttle = “enabled” mame_write_config = “enabled”

Normally it should save in save\mame\cfg but it doesn’t. There should also be a game.cfg everytime you load a rom but there isn’t. Mame2016 doesn’t have this issue

Well, that’s weird.

If i change mame_write_config = “enabled” to “disabled” it saves the files.

The option is inverted for some reason.


I think this option means mame configs located in the retroarch/system/mame/ folder, but i dont know how to make them work.

I wanted to make hiscores work in mame (0.212) but nothing happend.
I put the plugin folder from the upstream release in my system/mame/ folder,
generated mame.ini and plugin.ini from within the mame ui (press start+select ingame)
enabled write and read config and use mame ini paths as well, but the hiscores won’t save.

Some MAME folders don’t work in the RA system folder.

The CFG, DIFF and VRAM need to be in the RA Saves folder like this: Saves\mame\cfg.

Maybe the highscore files need to be in that folder too.

I tried this as well. But according this issue it is only a matter of configuration:

It only doesn’t work on my side. :thinking:


Don’t know why, but now it’s working. I did the same as explained in these post on github/libretro/mame over and over again but maybe previously i overlooked something:

I started new and deletetd the mame folders in retroarch/system/ and retroarch/saves/.

Steps to reproduce (the gui version):

  • download the official mame version from
  • extract the content of the plugin folder to retroarch/system/mame/plugin
    • (the other folders are not needed for hiscores)
  • in retroarch launch a game and in quick-menu turn on “read/write configuration” (write will generate a *.ini file for every game you play)
    • turn on “enable in-game mouse” as well
  • restart retroarch
  • launch game and press start+select on gamepad or enter+rshift to enter mame-ui
  • navigate (with your mouse) to the “plugin” settings and enable hiscores
  • go to “configure options” and save configuration

This generates the ui.ini, mame.ini and plugin.ini in the retroarch/system/mame/ini/ folder.
All the settings from retroarch are taken in.

Now it should work. You dont need tho change anything in this *.ini files.

The hiscores are saved in the retroarch/hi/ folder

1 Like

[INFO for linux-users]

(the guide above worked only on Windows)

It seems that mame doesn’t like dot-files (remember: everything is a file )
If you have all files in /home/user/.config/retroarch/ like me, than you have to edit your mame.ini file and insert the full path to your plugin folder.



pluginspath    /home/user/.config/retroarch/system/mame/plugins

[BE AWARE] if mame has already generated a [romname].ini then this will override your mame.ini and you have to delete or edit it. This only happens when write configuration=on. I recommend to leave it off.