Mame git 181 discussion

Hey @rcoltrane I’ve been considering setting up a repository of older compiled cores that are known to work well. I’m still not sure that’s something I want to try, but just to see how that might be structured I did ‘archive’ these two mame cores here:

What is the interest of having a core 0.174 while mame 2016 keeps the same compatibility but with improvements (osd and aspet)

True, maybe in this case there would only be a good argument for archiving the working mame2014 core that was posted.

I think if there is going to be an archive it should only be for cores where they are unique or represent a different/unique functionality or compatibility than what is currently available.

yes , but what is the pb with 2014 ?I’m not aware about it

I agree with r-type, there’s no need to store older 0.174 cores since the latest MAME2016 is an improved version and works fine with pre-lollipop devices. I just have to test the OSD again since I think that my old .cfg files might be the cause of the OSD malfunction here.

Regarding the 0.152 (2014) core, I tried to run it within my GPD XD and it didn’t work, so I don’t know if it’s worth keeping this core.

To me, even the older MAME2000 and MAME2003 cores could be removed from the RetroArch list, since they are way too outdated and it’s almost impossible to find suitable ROMS for these cores nowadays.

MAME 2014 on android thread: Is MAME 2014 [0.152] core (for android) in downloads?

Maybe that’s not relevant either?

The relatively huge RetroPie userbase almost all uses MAME 2003. ROMs are easy to source for MAME 0.78.

Ok I will look at 2014 to fix android build

Thanks works like a charm. You guys are great. I know have one with boot to BIOS and the other not. Is there any way other than rooting to put caprice32 back in retroarch

r-type, I’ve tested the latest MAME2016 core last night and yes, the OSD menus have some sort of an issue since its last modifications/updates. I did several core updates and Retroarch updates as well but the results were all the same. I’ve posted some pictures below to show you what’s going on here with the new core:

In these pictures you can notice 2 things: 1) Only the 1st value is displayed on the right corner of the sub menus and 2) All the other values seems to be offscreen, they are being positioned on the left side of the screen (see where the values are being displayed in the 3rd picture above in yellow). It seems that the rows are too big (or they are not being scaled properly) to fit in the submenu screen and thus, their values are being positioned offscreen.

Another issue with the OSD modifications is that when I try to open the DipSwitches submenu, it crashes with some games. It seems to happen with games that have the dipswitches represented graphically on screen, with the buttons drawn at the bottom of the screen. Games which have text items only are opening this submenu without crashing. One example of game that is crashing in the dipswitch menu is Black Tiger (in my case, blktigerb3). I’ve generated 2 log files of this crash happening, see tem below:

And finally, I could make MAME2016 to recognize my old input config files by renaming the mame/cfg folders to mame2016/cfg. After doing this, my buttons/screen settings are working again!

Ok for font i only re-enable old font , we have to check if the behavior is the same with mame 0.182 .as is the same mod for crash i will look at later maybe this week-end.

BTW, i finally sucess to build mame2014

1 Like

Thanks r-type, I’m going to test it now and will post my results here later.

r-type, I did some more tests this weekend with both MAME2014 and MAME2016 cores, here are the results:

MAME2014: it doesn’t work. Every game crashes upon start and when I try to load just the core, it does nothing. It’s the same results I had with the latest 0.181 core built for more modern Android OS. Here’s the LOG, so you can see what’s going on with this core:


  1. The OSD menus are improved, but now the effect of missing lines is inverted. Now, only the 1st line doesn’t display its value on the right side of the screen, while all the rest is ok (go figure :neutral_face:). However, the Dispswitch screen is working perfectly now with all the games I have , so this issue is solved. :grin:

  2. Some games stopped working and crashes when I try to run them. From the games I have, the ones that crashed are: blstroid (Blasteroids), mk (Mortal Kombat), mk2 (Mortal Kombat 2) and mk3 (Mortal Kombat 3. All the other games I have are working fine. Here’s the LOG file of the mk2 crash, maybe it helps to understand why these specific games stopped working:

These games are working fine with the older 0.174 core, so it’s a new issue that appeared within this new core. If you need LOG files for each game I can provide them, just let me know.

One final thing I would like to comment is that I noticed that the previous MAME2016 core (older) has a bigger size that the one you are compiling now. Here’s a photo of the sizes of the cores:

The ‘’ file is the old 0.174 core and the ‘’ is the new one you are compiling now. Why are the sizes so different?

Thanks!! RC

Mame 2014 and 2016 are now back in updater compiled with ndk10 , so update you core!

For mame2014 your log show Failed to open libretro core: “/data/data/com.retroarch/cores/” update the core with updater will solve you problem with 2014 core.

for the issue 1 , yes OSD have problem ,not sure how to fix this without using real font manager like in upstream .

for the issue 2 , regarding your log it’s seem a divide by 0 error is raising , I will look at when I will have some spare time.

for size mame2014 is smaller , because old mame was only arcade , newer are like ume = mess + mame so bigger. is current core like 0.182 now.

Thank you so much for putting up mame, mess and ume2014. That is awesome

r-type, I’ve updated my MAME2014 through Retroarch and it’s working fine now! And man, this core is great!! All my games are working with this one and they are even faster. All OSD menus are fine and are working properly, and this core saves NVRAM as well. However, it just needs one more fix…the name! This core is based over MAME 0.159, which was released in 25 Feb 2015. So, it should be named MAME2015. :grin:

Thank you so much for this MAME2014 (2015) core! And I hope you can figure out what’s causing those crashes in MAME2016. If you need further testing, please let me know :smiley:

Yes was 0.152 so 2014 at origin. And yes 2014 was great and faster for android device. Atetris is a good example to point speed issue with newer buld. But also newers mame are more accurate.

For mame2016. I’ve test to revert to 26 may 2016 commit and games like blstroid work fine. So pb are in the in between merge files.

@rcoltrane can you try this one ,

I revert to 26 may 2016 so one day and few commit after mame0.174 release , and I backport some commit I’ve done in 2016, so OSD menu and aspect should be Ok , and also backport old font from 0.170 maybe it will fix menu , i let you check.

game like wbml,mk,blstroid… should now work as expected .

If it’s fine i will push change in the mame2016 repo.

r-type, I’ve tested this new MAME2016 core you posted yesterday and the crashes with blstroid, mk, mk2 and mk3 are gone! The OSD menus are all working fine and the text in all OSD menus/submenus are fine!

One last game is crashing, but it was crashing in the old 0.174 build too that’s why I didn’t report it before. The game is Kung-Fu Master. This is now the only game that is crashing in my library with this latest MAME2016 core. All other things are just fine, congratulations!!!:smiley: Sidenote: kungfum doesn’t crash in MAME2014 though.

Here’s the LOG file for Kung-Fu Master crash, let’s see what’s going on there:

Just one final question: MAME2014 is saving NVRAM too, which is not being saved by MAME2016. Is it too difficult to ‘insert’ the save NVRAM code from MAME2014 into MAME2016? Well, thinking about it it might be interesting to enable savestates instead, since the official MAME 0.174 build supports savestates for almost all games. I’ll check Retroarch’s MAME core options to see if I can enable savestates and if it works, we won’t need to record NVRAM files anymore, since the states saved will store high scores as well.

And again, thank you very much r-type for listening to me and fixing everything!!

nice if it works , i 'll have to revert the current 2016 and apply the fix .

I’ll take a look at KFM although it seem to be a netlist pb . For nvram , I thinks savestate are supported in mame2016 , maybe @Tatsuya79 can confirm this.