MAME - TRS-80 Color Computer does not work ?!

Hello everyone !

I have a problem with MAME version 0.238 for Android. I would like to run the TRS-80 Color Computer system which works fine with RetroArch on Windows but not at all on Android ?!

Here is the cmd file that I use to start the Color Computer system:

cocoe -flop1 "/storage/emulated/0/Roms/Color Computer/Donkey King.dsk" -rp "/storage/emulated/0/RetroArh/system/mame/roms" -autoboot_delay 2 -autoboot_command loadm\"donkey\":exec\n 

When I run this cmd file I have a gray screen & nothing happens … this same command line works fine on RetroArch for Windows I don’t understand where the error is can someone help me ?!

I have also disabled the softlists in the options…

Thanks best regards !

The more recent versions of the MAME (post .227) core for Android do not support non-arcade games. This is my reference for the info Reddit - Mattel Handheld ROMs for MAME 0.235 (Current) RetroArch on Android

@Neofuuma hello thank you for your answer :slight_smile:

It’s a shame that Android is neglected because playing non-arcade games on the phone is very interesting, I don’t understand why ?!

Where can I find old versions of RetroArch & MAME for Android ?!

Thanks best regards !

I think someone in that Reddit thread had posted a link to a MAME core that did still have support for non-arcade games. I did also see that @hunterk had mentioned in another thread on these forums that there are eventual plans for a MESS core that would do the non-arcade stuff. That was in October of last year so maybe some stuff has progressed on that front.

I wish MAME and MESS would split again… It was a much more manageable situation IMO.


Hello I wish that the non arcade machines work correctly on Android like on Windows quite simply… I do not understand why the devs make a difference between the two ???

Well, the core became to large to even compile properly for Android, I think. So something had to be done to shrink it down. The most logical solution was to pare out the non-arcade drivers.

1 Like

Why too big I don’t understand the link sorry ?

MAME can emulate over 32,000 individual systems - that’s a bunch of code. While Windows can handle that, I imagine that an Android environment is much more limiting. Until the non-arcade bits are put into their own core - much the way it used to be on PCs with MAME and MESS - Android devices just can’t handle MAME in it’s full form.

1 Like

OK that’s really unfortunate then… I would love to play all those old machines on my phone… so what’s the alternative then ?

Greetings !

@Sebiohazard unfortunately I don’t think you have any other options aside from finding an Android MAME core version from .227 or earlier, before the removal of those devices.

@Neofuuma hello I downloaded versions 1.9.0 & 1.9.2 of RetroArch for Android (these are the only ones I found) but after installation there is no MAME core by default…

If we update the list of cores we go directly to version 0.238… it’s hopeless I don’t know how to get version 0.227 or earlier ?!

Greetings !

I always keep copies of cores…I think I have 226 or mame0.227…and coco does work along with many many other machines on Android

@sanchezmike01 hello thank you for your answer would you be kind enough to provide me with this version of RetroArch as well as the MAME cores which are fine ?

Thanks best regards

Here, hold this.

These are two versions of cores, 32 and 64 bits. Install them manually, in your retroarch.

@Sebiohazard your Retroarch version should not really matter, it would be best to use the most current one, and then just download and manually install the core that @svk linked.


I have same problem here

@svk Hello I downloaded MAME 0.226 versions (ARM v7 + ARM 64) with the latest version of RetroArch (1.10.0) for Android but there is nothing to do it still does not work ?!

I tried with RetroArch ARM v7 + ARM 64 nothing works… how to proceed please ?!

Greetings !

Hi) I needed these cores to run game&watch emulation. Because in subsequent versions of the mame cores, support for non-arcade systems was removed. These are the latest versions on the network where this support is available. And they work for me, on a 64 bit smartphone, and a 32 bit TV box. Unfortunately, I don’t know how to help you with emulation TRS-80, I’m not interested in this platform. Are you sure you uninstalled the newest core mame current? The new cores do not support non-arcade systems.

ps: In theory, nothing is impossible for a russian person, but I really don’t want to delve into all this just to help you, sorry dude)

@svk hello just a question… how do you run systems ? With a .cmd file ?