Mesen core doesn't work

I’m surprised it hasn’t been reported, but Mesen core stopped loading Famicom (and NES) roms for some days already. Didn’t try FDS. Whenever I try to load any rom, it says “Failed to load content” like something is not set up or broken usually. Still use Retroarch 1.9.2, but I have 1.9.1 on another computer, it’s the same. I see Mesen core updates regularly, but it still doesn’t work. I copied an old copy of the core taken from my Retroarch backup from some time ago, and it works. The current one does not. I first noticed this behavior on 7th of June. Had a core backup from 6th June, tried to restore it and seems it was already broken on 6th. I play Famicom often recently, almost everyday, and only with Mesen, so it should have happened around that time. I decided to patiently wait for a solution, but days pass, but it’s not fixed, so decided to let you know. Can you, please, look into it? Mesen is my everything :slight_smile: Together with bsnes and GenesisPlusGX.

1 Like

Hmm, seems fine here (linux 64-bit). Can you post a log of you trying and failing to load a game?

1 Like

Oh, hi, hunterk! Nice to finally meet you! I read a lot of very informative and clever posts from you that made me learn about many things. Thank you for that! And thank you very much for all you work!

Sorry it took so long, I had to learn how to log… And it seems there was no need to do that. I found the culprit during my investigation… It’s foreign symbols in the path… again? )) But it worked several days ago just fine ) Could you, please, explain this to dumb old me? Do these things have to be done each time by you? Do they create problems? Can’t this be done once and forever? ) I don’t know the story with particularly this case, as I said in another post, I’m far from coding, but as far as my deduction goes, it seems to me someone forgot to add some language support or something like that. Is it so? ) I guess this makes it not a core matter, but the frontend itself, right? Wait… The frontend remains the same, I’ve been using 1.9.2 since release. The only thing updated was the core. And other things with it. Hmmm… Maybe something else. I don’t remember updating assets, but I might have.

Ok… I’m Russian. I was going to get away from anything rather than latin in the folder names so many times before, nearly done it. I only left one ) Maybe a couple. Retroarch doesn’t like when some of the BIOS files lie in the shady characters path? (Mesen’s FDS and PUAE bios in particular, two cores most dear to me. goddamn, so much time wasted trying to figure that out :slight_smile: I didn’t find a single mention about PUAE on the internet based on google search. After I figured about Mesen, PUAE’s “Failed to load content” solved by itself) That’s fine with me, I moved Retroarch to the root folder. But, please, can at least my roms collection stay where it is? ))) Seriously, is it that important? If so, just tell me, and to further root out any possible problems, I can rename my folders. Once and for all.

Hi, thanks for the kind words :slight_smile:

This is a common problem, yes, but I’m surprised to hear that it popped up in Mesen after not being a problem in the past, since I don’t think there have been any major changes to that core since Sour retired some time ago. I’ll look into this further.

The easiest fix, obviously, is to just stick with latin characters in your paths, but I know that’s far from ideal, so we try to fix it on our end when we can. It shouldn’t be a problem in the frontend, but when the frontend passes the file path to the core is when it usually happens.

EDIT: okay, we pinned it down and it indeed is a problem with the core but it wasn’t apparent until we made some changes in RetroArch. We’ll get the core fixed up sometime soon, but in the meantime, if you update your RetroArch to v1.9.3, it should work fine as-is.

1 Like

Woah! I sat down to play a little of Ninja Gaiden Sigma, thought “Hey, I’ll just play through a level”, and here we are - the night has fallen behind the window! ) Sorry for falling out of the conversation! I’m very, very, very much interested in the results! It’s just that game ) I missed it so much ) It seems that I waited for eternity for these ports, an opportunity to play it again since I sold my PS3 in 2015. Yeah, an emulator can play it well and all, but it’s not the same as official port. I love the first one… The sequel is great too. But most of all, I love the original trilogy on the NES :slight_smile: So moving on to the topic…

I’m very glad to hear that!! Yeah, I was surprised when it just stopped working. Working yesterday and today it’s gone. But I just didn’t think at once about checking if the path was the problem. So if it’s a common thing, I guess if you see “Failed to load content” message, you have to mind the path to either BIOS or games :wink: That’s for people wondering about the cause as was the case with me. The only core that just refused to run at all, still giving me this error message, was “DeSmuME”. Oh man, for the life of me, I think I tried everything. It was stubborn… Same as PUAE ) I just tried putting a DS game to a root folder and what do you think? It worked! :slight_smile: I’m not limited to MelonDS anymore… Yay!! Always wanted to try DeSmuME. Yeah, this is an example of how a simple talk to people with same interests can solve all that you drag for years… Oh, those stupid names in the path!!! )) You know, before, for a very long time, I only used latin characters for folder names, because I came from DOS and we all remember how it was back then. I only changed a couple of years ago )) I’ve decided, I’ll rename them right now. I did, and everything works now. So it wasn’t about the length of the path, as I read from somewhere, it was the problem with characters…

Thank you for the suggestion! I was going to upgrade my Retroarch setup when 1.9.5 shows up, it’s just too much for me to reconfigure everything. In the past I was upgrading to each version and set everything from scratch. Nowadays I let myself skip a couple of builds :wink: Looks like in vain ) I’ll do it.

Oh, and I’m glad to join your forum. I’m an avid user of Retroarch now, picky person, so I might become useful for reporting something obscure someday :wink: Consider me as a tester if you need any, you and everyone around this wonderful project have all my respect and support. Thank you very much for all the explanation and your time! Please, take care!

You can just install over the top (or if you’re using the portable version, unzip it and then drag-and-drop it onto your existing installation, overwriting and merging any conflicts). It doesn’t come with any configs of its own, so it won’t overwrite your custom stuff.

Ok, nice to know merging won’t hurt, thanks! I use portable version. I’d rather unzip the new version and transfer configuration files there if I knew which ones. Do we need only retroarch.cfg? Are the controller configurations there? As far as I understood by briefly looking through different folders, only shaders configs are stored separately, right? each core has its own shader config. But, again, what if a feature is added to Retroarch and you’re still running with your config file from older version? ) Won’t it conflict or something? I don’t know, for me the perfect way to setup is to let new version of a program generate a proper configuration file and then configure everything again.

It’s just in the development some files are added, some old ones go. So if you copy over all the time, you may end up with a folder full of garbage files not in use anymore as I experienced before with some program, so I stopped practicing that )

Oh, one offtopic question, if you don’t mind, that has been bothering me for a while. Since the beginning of the year, once in a day or two, online updater updates all installed cores. I don’t think they are all new versions, more like a behavior made for backups, am I seeing it right? There’s no problem with updating small cores, but downloading 300mb MAME core everyday is something I’d like to avoid if it’s not necessary. Can you, please, make clear what’s the story behind this? I tried looking on the internet and again didn’t find any discussion on the subject. And is it possible to control the backups and all this.

The online updater has no way of knowing if any given update applies to your platform, so, for example, if a core gets a buildfix for platform X but you’re using platform Y, it’ll still look like an update for platform Y, even though nothing has changed.

So, if bandwidth is a concern, just don’t update all the time.

You are right, that must be my updating obsession ) Got it. I’ll be updating more seldom. Thanks for explanation!