Mesen Core


#143

The core does work good. There is a bug though. Like you I was thinking it might b Retrarch itself but it is not. The controller configuration for Retroarch itself does not work with Mesen core. I had to go into options with Mesen loaded and I had to configure it. I could tell my 8Bitdo Snes30Pro was configured right cuz remapping lined up perfectly the way Retroarch had it .It had B button as a button and A button as A Button. I tried another core Nestopia UE and the controller configuration worked by default. I did not have to go into and set it up For the core itself. Other then that the core works great


#144

It just has a different default mapping. Mesen is mapped in my preferred setup where jump is on the bottom face button and attack/run is on the left one. Just like most SNES games. But you can change that by going into controls in the quick menu with a game loaded in the core. Move A and B (and turbo A and B) to whatever face buttons you prefer and save a core remap.


#145

It’s an odd default I guess, if you’re playing with a NES style gamepad you’d be confused


#146

It’s a more ergonomic choice, of course, and it makes sense from an “accuracy” perspective, as well, since if you make an NES<->SNES adapter IRL, SNES-Y==NES-B and SNES-B==NES-A.

However, I know we chose our mapping convention specifically to mirror the physical layout of pads whenever possible, rather than what we think feels best, since that would be subjective and invite complaints. Of course, now we get complaints about it anyway :stuck_out_tongue:


#147

Yes if it was my call I’d remap it to B-A for consistency


#148

hi, Microphone does not react.Please fix.

As a simple confirmation method, an icon is displayed by microphone input in 2P mode of “Raid on Bungeling Bay (Japan)”.


#149

Thanks - the microphone issue should be fixed in the latest build on the buildbot (it’s also been moved to player 1’s L3 button, rather than player 2’s)