Missing save config option for MAME "Current" Core

Hello all. I have searched high and low and have not found an answser that works. MAME standalone shows the ability to save configurations. Using the same MAME access (TAB Button) brings up the config menu but the save option has been omitted. Inputs will not save using Retroarch MAME core input menu. Oddly enough, you can save game inputs individually using MAME/TAB but who has time to remapp hundreds of games? Can we please add this option? Thanks for reading and i hope this gets the attention it deserves.

Try copying the default.cfg or all your cfgs from your standalone to RA (in saves/mame/cfg). I think theres also a core option that has to do with reading and saving cfgs so maybe you need to have a look there as well.

I think this has to do with mame/ini files not the saves/cfg files.

Reading and writing to the *.ini is not usually beneficial unless you are using the command line with SW list support disabled.

FWIW, the standalone /cfg/*.cfg are identical to the saves/mame/cfg/*.cfg so copying them should work. :grin:

Great advice! I had never thought of that.

1 Like

Thank you both for the timely responses and i will update soon. I believe i’ve already tried this but i will try once more and report my findings.

Update: No success, once i copied over my MAME.cfg over to RA/saves/MAME/cfg the remapps were all over the place and not consistant with my Standalone MAME.For example; i have an arcade cabinet and 80% of my games use RetroArch which i absolutely love. However MAME core does not seem to play nice. I have a switch on my arcade cab where i can switch from analog to digital (for my racing games etc) I can play Enduro Racer with Standalone MAME and the analog works as designed. I play the same game in RA and analog does not respond. Another instance is with my fighting games. I have all buttons mapped correctly in MAME but using the copied cfg, the same fighting game buttons are mismapped. Ironically enough, if i open the MAME menu in RA using TAB, i can map the buttons correctly and they will work until i exit the game. Any and all help/feedback is greatly appreciated. Thanks for reading!

For the controls not being saved are you sure RA has the permission to write files? Check if any files are read only or try to run RA as an administrator.

If RA did’nt have permission to write to files, how would it be possible to map controls for games individually and save but not all games as a group. Im not running RA as administrator but i am curious if that will change anything. I will update once i give it a go. Thank you again for responding and i apologize for taking time out of your day to assist me. I really appreciate the assistance.

1 Like

Just a shot in the dark, but are you enabling game focus? I have successfully used “saves/cfg” files for various mame machines so I know it is possible in Retroarch.

I admit that I have only done this for software list machines though, not arcade games.

Edit: I just tried mapping an arcade game and the changes were reflected in my “saves/cfg/” file for the game.

We must be missing something.

Can you post your standalone cfg for Enduro Racer? I’d like to put it in my folder and see if the values are reflected in my MAME core.

Absolutley but the file is not allowed so i will show the contents on the Enduror Racer standalone MAME cfg-<?xml version="1.0"?>

1 Like

Well shoot. It’s obvious that there are no custom control entries in there. Explains why copying the files didn’t work.

I’ll do some R&D.

I just fired up Enduro Racer in standalone mame and randomly changed an assignment. I got this in the enduror.cfg

<?xml version="1.0"?>
<!-- This file is autogenerated; comments and unknown tags will be stripped -->
<mameconfig version="10">
    <system name="enduror">
            <coins index="0" number="1" />
            <coins index="1" number="1" />
            <port tag=":ADC0" type="P1_PEDAL" mask="255" defvalue="0" reverse="yes" />

Notice the

    <port tag=":ADC0" type="P1_PEDAL" mask="255" defvalue="0" reverse="yes" />

I’m unsure why your cfg file shows only the generic counters.

I think you may be onto something. I used your standalone MAME config in RA for Enduro Racer. The buttons worked but i could not steer left or right. However, after i manually remapped the buttons using TAB, my RA MAME cfg for Enduro Racer looks like this.-

1 Like

I am thinking maybe the reason why my MAME configs looks so empty could because i do input assignments (in general) for standalone and not individual input assignments. Kind of makes sense when i compare the two cfg files.

1 Like

Mine was just a test and wasn’t meant to be a functioning remap. You can maybe look at your “default.cfg” and copy and paste the relevant values from there.

As to your original post… I never had to actually “save” anything. Making changes and exiting the menu was enough.

It seems that copying your “cfg/*.cfg” should have worked anyway. I’m still a bit confused.

Unfortunately nothing is working. Thank you for your assistance. Maybe in the future, this option will make it’s way onto the RA MAME core.

Thank you for all of your help Duimon. I will not bother you any further. My apologies for taking much of your time. Have a wonderful day. :slight_smile:

1 Like

You should actually never see that screen in RA (Unless you need to for some reason?)

You must have the "mame_boot_to_osd = " set to “enabled” in your mame.opt.

These are my default mame.opt settings.

mame_alternate_renderer = "disabled"
mame_altres = "640x480"
mame_auto_save = "disabled"
mame_boot_from_cli = "disabled"
mame_boot_to_bios = "disabled"
mame_boot_to_osd = "disabled"
mame_buttons_profiles = "enabled"
mame_cheats_enable = "disabled"
mame_cpu_overclock = "default"
mame_lightgun_mode = "none"
mame_lightgun_offscreen_mode = "free"
mame_mame_4way_enable = "4way"
mame_mame_paths_enable = "disabled"
mame_media_type = "rom"
mame_mouse_enable = "enabled"
mame_read_config = "disabled"
mame_saves = "game"
mame_softlists_auto_media = "enabled"
mame_softlists_enable = "enabled"
mame_throttle = "disabled"
mame_write_config = "disabled"

The screen you are looking for is this one.

followed by this one.

General input should (AFAIK) be left at the default to work with the RA controls.

Something looks really wrong here. You should see a list of available systems. (Some will be greyed out.) There is no list in your shot.

I notice your MAME core version is 0.202. The current core is 0.251.

That screen is how i save inputs in the Standalone. I do see those screens in RA but my inputs only save using (Input Assignments (this system) none save using Input Assignments (general, which saves one config for all MAME games. I will give this a shot as this is a first i have heard of that- "mame_boot_to_osd = " set to “enabled” in your mame.opt.

Still no go. Do you have both Standalone MAME and RA MAME?, im curious, can you run GP Rider in both? Im curious to read your results. It’s another racer that all inputs will work in Standalone(Input Assignment(general) but only buttons work no directional inputs will work without using (Input Assignments(system) which is also the only way to save any inputs to any MAME games in RA.

I’m still concerned why you don’t see a list of available systems. You should at least see greyed out systems or systems like Jaaks that don’t require a bios.

Here is a shot of my MAME core OSD showing general settings and it appears that saving is enabled.

Notice my long list of available systems.

I don’t think your issue is due to any deficiency in the current core.

Is there any reason you don’t update your MAME core?

No apology is needed, this is what a community is for. :grin: