Mupen64plus Next broken?

Hey everyone,

Mupen64 won’t launch any games if GFX is switched to the parallel. The parallel core works perfectly fine however. A few months back mupen64 used to work also. I have just updated RetroArch and its cores to the newest version and now it doesn’t work anymore. What changed?

ParaLLEl-RDP has gotten some updates that aren’t included in ParaLLEl-N64, ironically enough, and those updates seem to be causing a lot of crashes for people due to more stringent vulkan requirements.

Oh, so you’re saying that the core crashes when upscaling? Is that it? O is it just broken?

No, it seems to be crashing on launch, unfortunately.

Bummer. Is this something that will be fixed or won’t the core work with vulkan from now on?

AFAIK, it still works in general. That is, it’s not broken broken, just some devices that used to work with it no longer do. It’s possibly affected by drivers, as well. AMD’s vulkan drivers have been weird lately and Nvidia’s have been weird off and on for a couple of years.

I guess I’m not smart enough to understand this. You are saying that it works for some people and not for others? I have an Nvidia GTX 1080 and never had issues with vulkan. Does the core work for you?

Correct. There are people using it right now with no problems. It doesn’t work for me because my only Vulkan-capable GPU is only barely so (Haswell integrated).

@SiriusVI have you tried using OpenGL and DirectX Video Plugins to see IF same thing happens?

Any information on whats changed? I mean, the plugjn was working fine all this time and was nearly perfect. Why fix something that isn’t broken?

It’s not changes to the emulation itself, but rather looks to be mostly vulkan compliance type stuff:

970 GTX here and still works fine with the latest version using ParaLLEl.

1 Like

Well this is really annoying. The core worked perfectly for me and now it’s not even clear if it ever will again?

Have you tried other emulators that also use ParaLLEl-RDP? AFAIK RMG and m64p both use the same code than the Mupen64Plus-Next core uses for that plugin, so if they work, something else in your installation might be messing things up.

No, I haven’t. I don’t know these emulators. I just know that Vulkan works with every emulator and retroarch core I use. It used to work flawlessly with Mupel64plus next the last time I tried a few months back, and now it doesn’t work anymore.

I don’t know what in my setup might be wrong exactly. I highly doubt it’s some “setting”. But I don’t have any clue to be honest.

Try with fresh core options. For example if I set upscaling to ridiculous 8x, it crashes.

1 Like