Mupen64Plus-Next v2.2 - VI/s stuck at 45fps


I’ve been having the above problem with this core for at least a year, maybe longer. I can’t get the VI/s to go above 45 fps, which gives games a judder (especially games designed for 60 fps, such as F-Zero X). This occurs using any of the 3 RDP plugins, i.e. GlideN64, Parallel, and AngryLion. This problem doesn’t occur with any of my other cores. The moment I switch back to the RA menu it jumps back up to 60fps. When I run my N64 games using Project 64 2.4 with GlideN64, they run at full 60 fps and games like F-Zero are silky smooth.

PC and Software Specs:

  • AMD Ryzen 5600x CPU
  • NVidia Geforce 1080Ti GPU
  • 16GB 3600 Mhz RAM
  • Windows 10 20H2 64-bit
  • Emulator and Roms running from an SSD
  • Retroarch version 1.9.3
  • Mupen64Plus-Next version 2.2

I’ve tried a variety of troubleshooting:

  • Played with all the core’s options (including deleting its options file and starting fresh)
  • Tried various latency, synchronization and frame throttle options
  • Tried disabling MSI Afterburner and RivaTuner
  • Ensured that Retroarch’s video was outputting the proper 60fps refresh rate
  • Tried both true fullscreen and borderless fullscreen options
  • Tried disabling shaders
  • Verified video drivers correctly use GL for GlideN64 and Angrylion, and correctly use Vulkan for Parallel.

Has anyone else had this problem? I’m not sure if it started when the Mupen64Plus core was replaced with the “-Next” core?

Thanks a bunch,


If you hit the spacebar, does it go >45 fps?

Hi HunterK, yes, I hit the spacebar on F-Zero’s title/demo screen, and the fps went up to between 120-180fps.

Your spacebar trick (which toggles fast-forward) sent me in a different troubleshooting direction, and I finally figured it out! Turns out the framerate limit was because I had the Rewind feature turned on. Turning it off made the framerate jump back up to 60fps. If I turned it back on and increased my number of rewind frames, then the fps would also increase. I couldn’t get it up to a perfect 60fps though, even when increasing my rewind frames to 100.

Now things are running much better; the only problem I still have is for games like Mario Kart 64 where the menu cursor disappears when Native res 2D Texrects is turned on. I found this thread that confirms the issue:

As per the responses (and I’ve verified this myself), this doesn’t happen with the standalone version of GlideN64 (using Project64). The ticket was closed assuming the problem was with either the Mupen64Plus-Next core, or how Retroarch handles its INI behavior. Hope this can be figured out.

At any rate, thanks for your help, HunterK!


1 Like

Ah, yeah, rewind. I’m glad you pinned it down, and thanks for posting your solution!