NES retroarch not working

Hello all,

Im new here, So i hope im posting in the correct location. I have gotten Retroarch set up correctly because my SNES is working properly. When i attempted to set up NES in the same manner using the NES / Famicom (nestopia UE) Or any of the other NES cores for that matter it fails. When i load that core from the online updater then try to select load content, than select file and core and then my NES rom it tells me that no core is available. Can anyone help me with this? Im not sure what i am doing wrong. Using this exact process works for me in SNES. I also tried multiple different roms to make sure that wasn’t the issue. Any suggestions?

I appreciate any help in advanced.

Which ROMs are you using? If no-intro, they went bonkers for awhile and distributed only header-less ROMs, which don’t work in any emulators. You’ll need to get ROMs from a headered set instead.

Um, how do i know… they are from Emuparadise. I was trying to play Contra , and also Super Mario Bro’s 3

Hmm. Those are probably fine, as I would assume they wouldn’t distribute ROMs that don’t work in emus…

In that case, we’ll need a log to know what’s up.

Where can i find the log to post it?

You’ll need to launch from a command line with the --verbose switch enabled. If you’re on Windows, shift+right-click in the RetroArch folder window and choose ‘open command window here’. Then, type in: retroarch_debug.exe --menu --verbose >> log.txt 2>&1 This will create a log file named log.txt.

ok um i tried to do that and i got two different outcomes… one of which was access is denied… the second of which was the handle could not be duplicated during redirection of handle 1. am i doing something wrong?

Im sorry for being a pain

yeah, probably doing something wrong :stuck_out_tongue:

Anyway, just open the command window and type in: retroarch_debug.exe --menu --verbose and it will print the log to the command window. You can copy/paste that somewhere like pastebin and then post the link here.

Thank you for the quick reply! I can see why you are an admin :slight_smile:

I’m not seeing anything useful in there. Did you try to load a game?

Ok so im going to , online updater > Core updater > NES Fiacom ( Nestopia UE) And hitting X > It loads to 100%, then i back up… go to load content >Select file and detect core > browse to my game > and it says no core available… Dunno what the heck is the deal. when i do that exact thing it works for SNES

Ok so im going to Online updater > NES Fiacom (Nestopia UE) which loads to 100%… Then i backup And go to Load content > Select file and Load core > Browse to my file select it and then it says No core available… This exact process works for SNES… Dunno whaat the deal is :frowning:

Instead of detecting the core, does it work if you manually load the core and then go select the game? Have you tried it with any other NES cores (e.g., fceumm)? Also, did you do all that stuff to get the previous log? because I didn’t see any of that going on in there.

OHH You mean like load that code and then run through the process so it generates a log of the issue? I get it now… I think i did it right this time

Here is what happened when i loaded the core manually and then tried to load the game without saying select file and detect core…

Here’s your problem: RetroArch [INFO] :: output_path: C:\Program Files\RetroArch\cores RetroArch [ERROR] :: Download of ‘’ failed: Write failed. Go into your core directory and manually unzip it. I’m not sure why this is happening but it’s easy enough to correct :slight_smile: <<EDIT: there’s not going to be anything in there because of the following:

EDIT: whoops, I do know what’s going on. Since it’s in your Program Files, it doesn’t have write access to its own directory. Move it somewhere in your ‘user’ directory (desktop, documents, etc) and it’ll work just fine

Move the entire RetroArch Directory out of program files?

HA! its working!! you are so awesome! Thank you so much!!!

Sorry for piggie-backing on this thread, but I’m also having problems with NES games.

SNES, N64, arcade ALL work in Retroarch. But not ONE of my 22 NES games will load under Retroarch. I’m using QuickNES as the core, but I haven’t tried any other cores. No errors, no nothing. None of the NES games load at all.

For what it’s worth, all of my roms come from emuparadise as well.

EDIT: By the way, I don’t have the same issue as the other poster since all of my files (retroarch, roms, etc) are under a user created “games” director off the C drive. I don’t have the read/write issue.

First, try another core. If that doesn’t help, we’ll need to see a log to know anything.