Numeric keypad doesn't work with ScummVM core

OK, so it seems that for whatever reason, the numeric keypad doesn’t work with this specific core (not sure about others).

So while reading the docs on the specific core here, it says:

"Additional ‘ScummVM Input’ Descriptions:

- Virtual Numpad + Numpad 5 + Numpad 0:

- Enables control during fight sequences in the ‘Indiana Jones’ series of games."

Which is exactly what I need: In “Fate of Atlantis” you can use the mouse (+clicking) to do the fighting sequences. But that option didn’t existed in “Last Crusade”. You must use the keypad in the fighting sequences.

According to the diagram on the libretro page, you need to press those 3 inputs at the same time to enable control through the numpad…? So that would be “right analog stick + R3 + R1”. Either way, it doesn’t work (plus, right analog stick doesn’t “emulate” the numpad, nothing happens in-game). I even tried to change the input driver to “raw” (as suggested by hunterk here: Numpad won’t work in Retroarch), but no dice :frowning:

The idea would be to skip using a gamepad altogether (I’m aware that’s the opposite of retroarch’s idea, but…) and just use the keyboard + mouse (obviously, with the numeric keypad being able to input/work). Sure, I could use the emulator itself (ScummVM), but it lacks the plethora of shader options RetroArch has available (including my personal favorites xBRZ and ScaleFX).

Please help?

Are you using ‘game focus mode’? It’s mapped to scroll lock by default. That will pass keyboard inputs directly to the core.

yes, mate. I’m using game focus, and it’s also not a “num lock” key issue… Besides, keyboard works fine. It’s just the numeric keypad that doesn’t, for whatever reason.

According to the diagram on the libretro page, you need to press those 3 inputs at the same time to enable control through the numpad…?

I think the documentation doesn’t mean “press these 3 together” but rather “these 3 buttons have these functions”.

AFAICT, pressing right-analog in different directions is what should do what you’re wanting. I’m not able to verify myself whether it’s working, as I don’t seem to have any games that want to work with it right now :confused: Does the right analog stick for you in any other cores? e.g., PS1?

It’s very confusing… I really don’t get it why they made it like this.

The right-analog stick works. But it works as an up/down for selecting menus inside the core (scummVM). For it to work inside the game (“Indiana Jones and The Last Crusade” being the best example), it would need to be able to output the numbers on the numeric keypad. Only it doesn’t. An easy way to check this, is to just place the cursor in the “search” field inside ScummVM and type in the numbers with the numpad: the cursor blinks (which means the core detects the input) but it doesn’t output numbers (which probably should, otherwise it doesn’t work ingame). Same way, if you position the cursor inside the search field, and move the right analog stick, the cursor also blinks, but (like the numpad) there’s also no number output.

I’ll check the game reference card… maybe there’s something I need to do to activate the numpad, who knows… Man, this is utterly frustrating.

Edit: nope, nothing to do with activating it ingame :man_facepalming:

Based on these:

Keyboard Inputs not Recognized in SUMMVM Core #176

Keyboard not working on Game Focus mode after updating from 1.9.0 to 1.9.1

Seems like a serious issue with the core. I even tried rolling back to RetroArch 1.9.0, but to no avail.

That’s it. I give up.

those issues appear to have been fixed:

Also, the fix was backported to the libretro fork this afternoon, in case it’s of any use it is now available for download from here:

Should also be available in the nightly repository 7 hours from now, here:

Have you tried any of the builds from here?

1 Like

First link is dead, I’ve tried the second link before starting the topic… I’ll try the one from the nightly build folder you sent, and report back. Thanks in advance mate :wink:

Edit: nightly build worked!! You’re a lifesaver mate… Thank you very much!! :heart:

1 Like