Numpad won’t work in Retroarch


#1

Ok I got a problem that’s making it hard to set up systems that use a numpad controller like the ColecoVision. Retroarch won’t work if you assign the buttons to your keyboard’s numpad. But certain ones do work for some reason here is a list.

0 works 1 doesn’t work 2 doesn’t work 3 doesn’t work 4 doesn’t work 5 works 6 doesn’t work 7 doesn’t work 8 doesn’t work 9 doesn’t work . works ent doesn’t work (but main enter key does)

turning num lock on and off has no effect.


#2

have you tried using a different driver? like ‘raw’ instead of ‘xinput’ (assuming Windows)?


#3

Not to mention, for some reason, certain Keyboards will not work.


#4

raw input did the trick thank you hunterk. Now if only Retroarch let you save global key configs to a core rather than the just the core remaps then I might finally be able to reduce my number of needed retroarch installs from two to just one. Almost still other reasons I need two installs anyway thank you.


#5

Now I got a new problem I was using the Gameboy for testing purposes when figuring out the numpad but when I tried out ColecoVision proper the problem came back. It works fin when I test the numpad with a Gameboy game but blueMSX won’t work. This would suggest something wrong with the core but it is exactly the same problem with certain keys working and certain keys not, just like my list. If it was the core’s problem why is it acting the same way Retroarch works when it has a problem with the numpad. Can a core force Retroarch to a certain input driver overriding the user settings? I’m at a loss here.


#6

If it’s just missing a few keys, they may be conflicting with RetroArch hotkeys. Have you tried using the “game focus mode”?


#7

None of my hot keys are set to conflict with the numpad also I have it set so that you have to be holding down a certain key (in my case the tilde key) in order for hotkeys to work precisely so that stuff like this won’t happen. And if that wasn’t enough I tried this “game focus mode” and it had the complete opposite effect it made so nothing worked. It’s got to be a core issue since the other cores don’t have this problem but again I find it weird that it mimics the same inconsistent functionality that retroarch had with dinput.