Nvidia Shield TV 4K(2017) Controller Overly Sensitive


#1

Hello!

I just received a Nvidia Shield for the holidays and I’m running into some issues. When I launch RetroPie, even on a fresh install, I’m running into an issue where the directional pad doesn’t function properly. When I press Up or Down on the Dpad, the menu travels to either the top or the bottom of that menu’s list, respectively. If I press Left or Right on the Dpad, the menu goes left or right incredibly fast. I can tap left or right quickly to move through the menu left or right but I can’t do the same thing going up or down. It almost acts like I’m pressing Page up or Page down on a keyboard while viewing a website. The only workaround I have is to press up or down, depending on the direction I need to go and then pressing the Nvidia Home Button, which takes me back to the shield home menu, and then going back into Retroarch and pressing the up or down again, depending on the direction I need to go. This allows me to traverse a menu one item at a time. Doing this enabled me to make my way to the Bind All menu option but even after rebinding everything, and I’m not even sure everything rebound 100% correctly (I don’t think Retroarch is reading the Triggers or Joysticks properly), it still does the same thing.

Is this a known issue and is there a fix or is this something new that came out with this newer version of the Shield?

I posted on Reddit about this issue and I was told to investigate to see if the USB ports were the issue. They were implying that some USB 3.0 Hard Drives or Flash Drives can cause interference and throw off the controller. That didn’t sound right to me but if anyone has an article or KB that I can refer too I would greatly appreciate it.

I also attempted to Google it but I wasn’t able to find a fix that directly correlated with the hardware version or exact issues I was having.

Any assistance would be immensely appreciated! Cheers!

(P.S. I can record and upload video to Youtube if it better demonstrates the issue I’m having)


#2

I think we all have 2015 models, but are you running the latest firmware and everything? you might try completely uninstalling and then reinstalling to see if something has gone wrong. Typically, the Shield ATVs are just install-and-go, with the Shield controller autoconfigured and everything.


#3

I have uninstalled and reinstalled multiple times just to check. When I get home I’ll double check to see if the Shield is on the latest firmware. From the videos of other people on Youtube I was expecting it to be install-and-go but so far my experience hasn’t been that way. Hopefully, I can figure this out soon.

Sorry about that (2017) bit, I’m not 100% sure how everything works yet so I just wanted to be as thorough as possible.


#4

Just to confirm its only a RetroArch issue. All other apps are fine


#5

I can confirm on my 2015 Shield TV, that using the Shield Controller (Original), Retroarch is unusable. I have to use a separate keyboard to even navigate.

I was using the most recent Nightly Build when testing.


#6

I’m using a 2017 Shield TV and I have the same issue. When Retroarch first loads up the input is fine, but it breaks a few seconds later rendering the UI completely unusable. Realy nasty bug.

I’m using the stock NVidia pad. I’m on Retroarch v 1.7.1.


#7

I don’t seem to have this issue on my STV 2015. I do get the odd double press and I would say the controls are sensitive but it’s not a problem here.

Not sure what RA version I have but think it’s 1.7.1.

I will keep an eye on it.


#8

I’m using the latest version which recently came out for the Shield and the controller bug is unchanged. It’s still very difficult to get the UI to remain functional for longer than a few seconds. As before it starts okay, but very quickly any press of the dpad jumps many entries in the UI all at once.


#9

Hi, I have a 2017 Shield and RetroArch has been working fine, but after updating to 1.7.2, my controller is unusable. It is exactly as NullTie described, jumping up and down menus. Surely more people must have experienced this?


#10

Another update on this - as the Shield controller is completely unusable now in the Retroarch UI I tried pairing my Shield with another controller. I had a spare 8Bit-Do FC30 bluetooth pad to hand, so I set that up, and to my surprise, Retroarch is working fine with it.

It could be that this particular bug is specific to the Shield controller. I know NVidia actually update the firmware on the pad (quite why a controller needs firmware updates remains a mystery), so perhaps something they’ve done has broken Retroarch?


#11

I had similar problems with the Shield controller, the analog stick would get all wonky and in retroarch would scroll all over the place in the menu. Finally had enough of it and paired an old Dual Shock 3 controller, that is what I use now and it has had no problems since. Honestly the shield controller isn’t all that great to begin with so I don’t miss it.


#12

Having used an 8bitDo controller in Retroarch as a substitute for a while I’m finding the bluetooth lag a real game killer. The Shield controller is wi-fi direct and much less laggy.

Could someone please take a look at the controller issues on the Shield? It would be great to get the official Shield controller working again.


#13

I’ve had this issue as well. It might be an issue with having multiple controllers at one time connected to the Shield TV. Since I removed all other controllers and re-paired the Shield Controller, I haven’t had the issue again.


#14

I own the 2015 model as well, and have had this issue for over a year. On the latest OS and Retroarch, and all Shield controls are updated etc.

I’ve basically stopped using RA on my Shield TV as a result, and I love RA. If there’s any way this could be finally fixed it would be much appreciated.

Yeah, I know people will say don’t use the Shield controller, but I happen to really like it and find it to be very good, and it works perfectly on everything else on my Shield TV.


#15

The problem is the Shield controller itself. I recently had to RMA mine due to the right stick always drifting upward. It is a wide spread problem as you can read on the Nvidia Geforce Forums/Shield TV.

I had the same problem with Retroarch as others have posted and since I got the new controller from Nvidia it works fine. However I’ve paired my PS3 controller and use that for Retroarch since I don’t want to chance the Shield controller going bad again.

The only thing I use the Shield controller for now is when I open a web browser such as Firefox or Chrome the right stick acts like a mouse pointer which is super useful, and as far as I know the Shield controller is the only controller that has that option available.


#16

Throw away that controller. It is one of the worst controllers I’ve ever used.


#17

I don’t think it’s just the Shield controller.

I experienced the same behavior even when using an Xbox BT controller.

Also, my Shield controller works perfectly with all other apps, including emulators. This issue only happens with Retroarch.


#18

Is there still no fix for this? It cripples Retroarch on the Shield with the official pad.