Obscure Video Games x RetroArch x Difficulty in configuration

Good morning guys ! :grin:

I recently started setting up my RetroArch. Mostly alone, and some others through the help of other users of retorarch and also in this forum.

However, I spent almost an entire day trying to configure some more obscure systems but totally without success. In short, I didn’t find information on the internet that would help me. And on the Libretro website there is no specific information about these video games.

Are they:

  • AMSTRAD GX-4000


  • CASIO PV-1000


  • CDI




these are the ones … all are systems that are emulated by MAME. But I couldn’t make any of them work. Basically all that is missing to configure my RetroArch.

Could someone help me? I have no idea where to look. All the users I contacted said they never set up such video games.

This guide should help: [Guide] Play Non-Arcade systems with MAME or MESS

Thank you. I will see that.

I followed I believe the steps described in the link. When I click to start a game the retroarch window opens showing the information “initializing”. However, in the same second that this window opens it stops working. I have to close everything because it locks the retroarch.

It is funny to see this difference in the settings part in RetroArch. For the other systems, everything is very simple, but for the more obscure ones, a lot of work is needed. And sometimes without result. I would love to see all my systems running through a single Front-end. But it seems that I will not succeed.

There are some difficulties like:

  1. The names of the games cannot be those edited by us. It is necessary to rename the files to that small name that the MAME recognizes. I don’t understand why, because using the MAME (Stand alone) emulator, the emulator can recognize the game regardless of the name contained in the file.

  2. We cannot add games where we want. It is necessary to place them within a certain directory. Why?

  3. Unlike the most famous systems, retroarch does not warn us if any bios are missing for the most obscure video games. If it were possible, the retroarch could improve on that part. Creating the possibility of specific configurations for these systems. In order to make your configuration easier. For until the present moment it is almost a “improvisation” what we need to do.

I am NOT DISTRACTING retorarch. Quite the opposite. I love this program and I intend to use it for many years. I just want to see an improvement in that part. Only that.

If anyone has already succeeded please let me know here. Because what I could do alone I already did.

If the game shows “initializing” and then does not launch, there is likely a problem with your setup. I’d follow the instructions in the link, specifically the part about running from the command line to see what error is listed. It will likely tell you about files that can’t be found (bios files or romset files).

1 Like

I’m not sure … Perhaps the problem is the file name.

Type: is the name of the file important when it is compressed?

Exe: cdi game recognized by MAME = dimo.zip

have a problem or does the contents of the dimo.zip file have a different name?

example: “Dimo’s Quest.chd”

Filenames are exact in MAME, as is the folder name as described in the guide.

The simplest setup is using files from a “romset” of the same exact version of the MAME version you’re using. If you have different versions there’s a chance that they’re not compatible (although I’ll say from personal experience, with the older obscure systems the versions rarely change so thats typically not the problem). That is why running from the command line is helpful - the program will spit out an error of some kind to tell you what file it can’t find.

Run from the command line you said …

where do you perform it?

At the command prompt?

Could you copy one command line your here to serve as a model for me? thank you

U dont need mame softlist naming to run the games…instead use command line to run the game from any location

1 Like

The guide linked above has examples which you can copy and modify for your setup. For your example gx4000:

On a mac I use the following in a command prompt:

/Applications/RetroArch.app/Contents/MacOS/RetroArch -L ".../path_to_cores/cores/mame_libretro.dylib" ".../path_to_games/gx4000/barb2.zip"

On windows it would be the following in a command prompt:

"...\path_to_program\retroarch.exe" -L "...\path_to_cores\cores\mame_libretro.dll" "...\path_to_games\gx4000\barb2.zip"

I understood that it has to be from the command line. my doubt now is how to produce a file with a command inside it. are these .bat files?

I created the .bat file Whenever I run the file, this message appears:

“A syntax for the file name, directory name, or volume label is incorrect.” …

That’s the command I’m runnin:

“D:\Jogos\RetroArch\retroarch.exe” -L “D:\Jogos\RetroArch\cores\mame_libretro.dll” “D:\Jogos\RetroArch\system\gx4000\barb2.zip”

The command works …

RetroArch opens but is stuck on this screen below:

I just tried to run this command line from the PHILIPS CDI system.

“D:\Jogos\RetroArch\retroarch.exe” -L “D:\Jogos\RetroArch\cores\mame_libretro.dll” “D:\Jogos\RetroArch\system\cdimono1\hotmario.zip”

But the same thing happened. RetroArch opens but crashes.

Any idea what might be going on?

The GX4000 system:

  • does not require bios.

  • the rom is named correctly

  • the command is right.

What am I missing?

after I forcefully close the retroarch the command prompt screen has this information below … there are no errors.

It doesn’t seem to be printing anything. Try adding ‘–verbose’

“D:\Jogos\RetroArch\retroarch.exe” -L “D:\Jogos\RetroArch\cores\mame_libretro.dll” “D:\Jogos\RetroArch\system\cdimono1\hotmario.zip” --verbose


a lot has appeared now. I saw that there was an error at the end. But I honestly don’t know what that means.

The link:


I am also downloading updated roms. Suggested by someone else on the forum. We will try to eliminate the possible problems right …?

Your log says it cant find some files:

cdic.bin NOT FOUND (NO GOOD DUMP KNOWN) (tried in cdimono1 cdimono1)
slave.bin NOT FOUND (NO GOOD DUMP KNOWN) (tried in cdimono1 cdimono1)
WARNING: the machine might not run correctly.
hotel mario (1994)(philips)(eu)[!].chd NOT FOUND
Fatal error: Required files are missing, the machine cannot be run.

The required files for that one are listed directly in the guide:

...path_to_my_game_files/cdimono1 (folder)
     hotmario.zip (Dummy / Empty File)
     hotel mario (1994)(philips)(eu)[!].chd (CHD File)
     cdibios.zip (BIOS File)
     cdimono1.zip (BIOS File)
     cdimono2.zip (BIOS File)

Now I think you can follow how to troubleshoot on your own. Good luck!

Thanks a lot for the help!!!

I just downloaded updated MAME roms here too. The first system I tested has already started to work! Thank you very much!!!

1 Like

Hi Zack. A doubt. The xml file I have is named “cdi” and not “cdimon1”. So shouldn’t the folder containing the games and bios have the same name as the .xml file? or can the xml file be called “cdi.xml”? And the folder of games and bios is called “cdi” (folder)?

cdic.bin NOT FOUND (NO GOOD DUMP KNOWN) (tried in cdimono1 cdimono1) slave.bin NOT FOUND (NO GOOD DUMP KNOWN) (tried in cdimono1 cdimono1)

What does this information mean? Is the emulator trying to find the “cdic.bin” and “slave.bin” files within the cdimono1.zip file? It is?

ps…All that remains is to configure the PHILIPS CDI and FM TOWNS systems. Finally, this battle is almost over. Just finishing downloading good roms. :grin: