PCE_Fast BIOS Core Info Update, + Game Loads into Audio Disc?

Up until tonight I’d been using the SGX core to play NEC games as, at the time, I wasn’t able to get the PCE core to load Arcade CD-ROM^2 games what-so-ever.

Tonight however, I’m wrapping up loose ends in the library, and the LAST GAME I need for the USA set is Magical Dinosaur Tour for the TurboGrafx-CD. Well I found a redump verified copy, plugged it into my SGX core… and it’s loading it like an Audio CD, and not a game. I even tracked down 2 other sources for the game thinking that was the issue… nope

So, after trying all 4 BIOS options with the game (syscard 1, 2, 3, and even games express for good measure), and getting nowhere, I figured I’d try out the PCE_Fast core again.

The good news is, it’s now loading my Arcade CD-ROM^2 games. Even appears to be a specific setting for this format in the core options… anyway, so I tried all those same BIOS options with PCE_Fast, and no luck…

I’m seeing however that PCE_Fast ALSO added options for syscard2 (US) and syscard 3 (US) on top of the previous 4. Personally, I think this is utterly FANTASTIC, so thank you to whoever took the time to add in these distinct options. There’s just onnnnnnne little itty bitty titty problem… the core info file doesn’t tell me what I’m supposed to name these files. I updated core info files twice to make sure I wasn’t crazy.

Just to be clear, I don’t think these 2 issues are related or anything, they just both popped up at once, and I need help with both… better than making 2 posts I figure lol.

In theory, since Magical Dinosaur Tour is just a TurboGrafx-CD game, it should load fine with the syscard2.pce that I’m currently using, which is the US variant that actually says “TurboGrafx-CD”, as well as either syscard3.pce as everything else does. However nothing works.

I would love some help here, I’m one title away from closing out the US side of this system, and being able to operate the US BIOS cards on top of that in particular is like a nice bow on top of the whole thing - if I can get it to work. :frowning:

If you get a verbose log, it should tell you what it’s looking for. If you post here with the names and checksums, I can add them to the core info files.

1 Like

Alright, I ran the verbose log and found what it was looking for. I went ahead and just ran the whole gammut of these things to be thorough. Here’s what I found:

Full Name: PC-Engine CD-ROM System Card v1.0
Filename: syscard1.pce
Checksum: 2b7ccb3d86baa18f6402c176f3065082

Full Name: PC-Engine CD-ROM^2 System Card v2.0
Filename: syscard2.pce
Checksum: 3a456f0eccff039eb5ff045f56ec1c3b

Full Name: PC-Engine Super CD-ROM^2 System Card v3.0
Filename: syscard3.pce
Checksum: 38179df8f4ac870017db21ebcbf53114

Full Name: TurboGrafx-CD System Card
Filename: syscard2u.pce
Checksum: 94279f315e8b52904f65ab3108542afe

Full Name: TurboGrafx-CD Super System Card
Filename: syscard3u.pce
Checksum: 0754f903b52e3b3342202bdafb13efa5

Now, this is where a bit more dancing about comes in as the core is missing 2 BIOS options. The first is the PC-Engine v2.1 card:

Full Name: PC-Engine CD-ROM^2 System Card v2.1
Filename: syscard2.pce (Maybe should be syscard2.1.pce)
Checksum: 3cdd6614a918616bfc41c862e889dd79

This is the one I’m using in place of v2.0, I’m not seeing any information online, but if I remember this card had some alteration that was present in the US card that was backported to Japan. Hence 2.1

In addition to that, there are 2 version of the Games Express System Cards.

Full Name: Games Express CD Card (Blue Ver.)
Filename: gexpress.pce (Maybe should be gexpressblue.pce)
Checksum: 6d2cb14fc3e1f65ceb135633d1694122

Full Name: Games Express CD Card (Green Ver.)
Filename: gexpress.pce (Maybe should be gexpressgreen.pce)
Checksum: ccf8590e2e7ac4a08bcc1d77ec168917

I have no idea what one it’s actually looking for, but I went with the Blue version since it’s a much larger size. I can’t find much info about the 2 variations though.

Hopefully this helps in updating the core file, though the additional cards here aren’t present in the core options, so not all of it will be immediately useful in that regard. If we see these versions get added though, we’ve got the info here.

Now, all that aside, throwing all EIGHT of those cards at Magical Dinosaur Tour, all I get is the audio player - or in the case of gexpress just an error. At this point I’m not sure if it’s a compatibility thing or the redump game is bad or what…

Should mention these BIOS cards are from the No-Intro set as well, not just random crap I got off a taiwanese website or something hahaha.

1 Like

Hello, it looks like there is something wrong with the .cue file of the redump game, it only contains audiotracks. I compared it with the japan version of the game and changed track 2 and 4 to MODE1/2352 accordingly. Now it works. My .cue file looks now like this:

Magical Dinosaur Tour (USA).cue:

CATALOG 0000000000000
FILE "Magical Dinosaur Tour (USA) (Track 1).bin" BINARY  
  INDEX 01 00:00:00  
FILE "Magical Dinosaur Tour (USA) (Track 2).bin" BINARY  
 TRACK 02 MODE1/2352  
  INDEX 00 00:00:00  
  INDEX 01 00:02:74  
FILE "Magical Dinosaur Tour (USA) (Track 3).bin" BINARY  
  INDEX 00 00:00:00  
  INDEX 01 00:02:00  
FILE "Magical Dinosaur Tour (USA) (Track 4).bin" BINARY  
 TRACK 04 MODE1/2352  
  INDEX 00 00:00:00  
  INDEX 01 00:02:74

Duuuuuuuude! Thank you! I don’t know a lot about cue sheet structure, so I wouldn’t have thought to check this. Particularly since it was from redump (They are typically the A-#1 go-to for cue sheets aren’t they??)

Sadly, I seemed to have deleted the multi-track .bin copies I had and kept the .chd I made as sort of an “oh yeah, I need to fix this” reminder in my to-do folder on my HDD… and I’m at work so I can’t go out and grab another copy to test this at the moment.

I did however learn how to change my “.bin/.cue to .chd” .bat in an attempt to test this - before realizing it only spits out the single-track .bin/.cue file I fed it in the first place XD XD XD - so that was fun before realizing I’m an idiot hahaha.

I’ll be sure to try this like, as soon as I get home tonight and report back, but you’re a damn saint either way for tracking that error down. Much, much appreciated.

Ah yeah! That totally did the trick. Thanks so much! <3 :smiley:

I don’t honestly know if it’s worth mentioning or not, but maybe? So I’m gonna drop this here too. Using the .cue sheet you provided absolutely made the game go - so this is def ‘extra’ if anything.

Whenever possible I convert .bin/.cue to CHD, which requires I convert multi-track to single-track images. Normally I do this by mounting in Daemon Tools and ripping back to the disc via IMGBurn.

I ran into a not so uncommon issue with it being stuck analyzing track 1 session 2 - and just spinning on that into infinity.

After some googling, I nabbed a copy of ISOBuster and used that to do the conversion instead of IMGBurn… and I have never seen a .cue sheet like this - I mean it’s way bizarre to me:

FILE "Magical Dinosaur Tour.bin" BINARY


  REM SESSION 01        ; Not supported by other applications (*)
      INDEX 01 00:00:00
      REM MSF: 00:00:00 = LBA: 0
    TRACK 02 MODE1/2352
      INDEX 00 00:44:66
      REM MSF: 00:44:66 = LBA: 3366
      INDEX 01 00:47:65
      REM MSF: 00:47:65 = LBA: 3590
      INDEX 00 14:52:74
      REM MSF: 14:52:74 = LBA: 66974
      INDEX 01 14:54:74
      REM MSF: 14:54:74 = LBA: 67124
    TRACK 04 MODE1/2352
      INDEX 00 17:50:19
      REM MSF: 17:50:19 = LBA: 80269
      INDEX 01 17:53:18
      REM MSF: 17:53:18 = LBA: 80493

REM (*) SESSION directives are unfortunately not properly supported
REM     'out there'.  IsoBuster however supports them !

Maybe it’s nothing to be concerned about, maybe it’s a sign something is broken beyond repair - I honestly don’t know lol.

I will say though that the game’s single-track .bin/.cue does launch the game after conversion - and so does the .chd converted file as well. So really, there doesn’t ‘seem’ to be a problem, which is why I’m just trying to present this as maybe a footnote.

I will say I also tried to clean up all that extra info in the .cue sheet haha but as soon as it pulls up the CD Card Bios you get “uncorrectable data at sector 1” lol so it wasn’t as straight forward as I had assumed it ‘might’ be.

What? chdman handles converting Redump format multi track .bins just fine. I don’t remember running into any problems converting them for any systems. Except the new .bin/.cue ones for Dreamcast, which you just need to swap the .cue for a .gdi.

1 Like

…if that is true I can’t even calculate how many hours I have wasted doing the initial conversion lol.

Maybe it was a limitation of the bat file I’m using…?

 @echo off 
set rompath=W:\Games\Convert
set destpath=W:\Games\Converted
for /R "%rompath%" %%G in (*.cue) do ( 
echo === Converting %%~nG to CHD ===
chdman createcd -i "%%G" -o "%destpath%\%%~nG.chd" -f 

My bat is simpler:

for /r %%i in (*.cue, *.gdi) do chdman createcd -i "%%i" -o "%%~ni.chd

But I’m not a batch script expert, so I’m not sure if some part of yours is causing an issue with multi tracks. This simple one is nice in that you don’t have to edit anything in it. Just drop the .bat and chdman.exe in a folder with your dumps and run it. It even picks up stuff in subfolders.