Picodrive: cropping overscan crops too much!


#1

Hey guys, when I disable the “Show Overscan” option in PicoDrive, a bit of the image gets lost at the bottom.

Here’s Turrican with the “Show Overscan” option turned on:

Here it is, turned off (i.e., overscan gets cropped):

Is there a way to crop the overscan, but not part of the screen?


#2

Is that a consistent thing? That is, is it always the same overscan with every game?

Overscan varied from TV to TV, so programmers were aware that anywhere from 5% to 15% of their image was going to be lost to it and to avoid placing important information where it might get partially chopped off.


#3

Hey Hunterk, thanks for your quick response.

The other games I’ve tried are QuackShot (World), Sonic & Knuckles (World), ToeJam & Earl (World), Zero Tolerance (USA, Europe), Golden Axe (World), Golden Axe II (World), Golden Axe III (Japan) and Mickey Mouse - World of Illusion (Europe).

Seems like they’re all equally affected.

EDIT: The good news is that none of these have junk data in the overscan, as far as I can see. :slight_smile:


#4

Looks like this is pertinent code:

I suppose this could be turned into an option instead of a hardcoded value.


#5

overscan has always been -8px, in some rare cases even 16 (aka sm3 on NES) so the cutoff should be expected (havent look at code and what it should look like with overscans shown)


#6

Hello, gentlemen! Yeah, it would be great if this could become customizable in the future, since it seems Picodrive at least crops parts off the game graphics consistently (based on the set of data I have).