PicoDrive Issues

When I start the 32X version of Virtual Racing on PicoDrive, the screen freezes around the 11th position in the demo. It was the same in a new environment except I installed PicoDrive core. Only PicoDrive can run 32X. Is there any way to fix this? The environment is Windows.

1 Like

I don’t have an issue here.

The first thing I would try is a different copy of the rom, in case the one you have is corrupt.

1 Like

Thanks for the reply.

I reviewed the core options after that and changed the Renderer from Accurate to Good or Fast and it fixed it. I remember it used to work with Accurate.

1 Like

I am using Accurate. My advice still stands. :grin:

1 Like

Just tried and it works for me as well with the Accurate renderer: the demo plays with no problem.

Maybe try a different video driver?

1 Like

Thanks for the reply.

ROM checked. Japanese version, CRC is 0908E888. Also worked fine with Fusion 3.64.

I also tried all video drivers, but the screen froze at the same place.

Is this a problem only with the Japanese version?

Confirmed that it hangs at position 11 with the Japan version of the rom.

Seems the rom or emulation is flaky. Resetting the system fixes it but it will lock up at any initial boot.

1 Like

Resetting it fixed it! Thanks!

Also, I was mistaken, but no matter what the Renderer value was, the screen froze at about 11 on the first boot.

Also, I had no problem with the Android version.

Maybe it’s just a problem with the Windows version. I hope it will be fixed.

Try turning off Dynamic Recompilers. "Core option"→Performance. PicoDrive is a light core, so even with Dynamic Recompilers turned off, you should not experience any speed problems.

1 Like

Thanks for the good info!

I turned off Dynamic Recompilers and it worked fine on the first boot.

I will keep this setting for a while.

1 Like

I tried also the Jap version and it didn’t hang. :thinking:

When I run the latest version of Windows nightly with a new expansion and initial state, it still freezes.

It is the 32X version of Virtua Racing Deluxe, not the MegaDrive version, right?

If it doesn’t hang, I’m surprised.

I’m not on nightly, I let the demo loop few times: no hangs.

rom: Virtua Racing Deluxe (Japan).32x

pico drive:


I see.

This may have been caused by an update to either RetroArch or PicoDrive.無題

1 Like

If you want to try, and maybe exclude the RA 1.18, here is my core.

The version of Core you are using is the same as the Stable version (dated 2/3).

I tried it in a 1.18.0 environment and it worked fine.

But I will continue to use the Nightly version as it may contain other improvements.

I also found a workaround for the problem in the other post.


1 Like