PlayStation 2 cores: PCSX2, Play!

Hello

Thought I’d start a new thread rather than necroposting on ‘PlayStation 2 cores

My noob question is this: are both cores still currently WIP as far as stable builds & nightlies are concerned? The vids on the blogposts look amazing:

https://www.libretro.com/index.php/category/playstation2/

…but contrary to the guidance on there, I can’t see either core available in my online updater; have they been pulled for now, could my system just not be powerful enough so they don’t show up for me, or am I doing something else wrong?

PCSX2 still hasn’t been released publicly (the code is out there, so people can compile it if they want, but it still has some pretty glaring bugs that keep us from being able to support it). Play! just isn’t part of our build infrastructure yet. You can download a nightly win64 build here: https://github.com/hunterk/libretro_builds/releases/download/Windows_64-bit/play_libretro.dll.zip or various linux/andrdoid builds here: https://gitlab.incom.co/libretro/Play-/-/pipelines

1 Like

Hi - so I just downloaded the play_libretro.dll.zip, extracted the .dll and dropped it into my cores folder with my other cores; it shows when I go to ‘load core’ but when I select it, RA won’t let me load it like it would any other core, just backs out to main menu and returns ‘no core’.

I had a friend send me the MAME 2016 .dll recently as that core was (and still is) unavailable in my core updater and that works fine now - is there some other step you need to perform to install a nightly .dll ?

I think you need a “play_libretro.info” file in the “info” folder of RA. You can normally get this by select “Update Core Info Files” from the menu.

Thanks but I already tried that before posting, just checked and I do have the play_libretro.info file; I also ran Update Databases, no change.

I note, the system requirements state: “This core will require OpenGL on the desktop and OpenGL ES3 on mobile devices.” -not too familiar with this stuff but I checked under RA System Information and it states:

“OpenGL Support: Yes, OpenGL ES Support: No”

-would assume this means it should run?

The OpenGL stuff is probably fine (assuming you can run, say, mupen64plus-next core), but the Play! core requires some MSVC++ runtime stuff, too, I think. You may be missing those. You can try getting the 2019 runtime from microsoft (free download) and see if that helps.

You mean download and install the ‘vc_redist.x64.exe’, here ? I’m on Win10 64bit. Again, sorry, not 100% sure about this stuff!

I don’t have any N64 ROMs to test but the mupen64plus-next core downloads and that one loads, at least :slight_smile:

yeah, that’s the one. dunno if it’ll solve your issue, but it’s worth a shot.

Thanks for the steer but it didn’t help. I can scan the PS2 rom just fine and it shows up in it’s own playlist as normal but when the core list pops up when you try to run it, Play! core doesn’t show; it is only visible if I go to Load Core; where it doesn’t load! Weird.

Oh well, I may try another nightly at some point, otherwise guess I’ll let the development ‘mature’ a little more and wait for it to hit the core updater, unless anyone comes back here with any other bright ideas.

For your test you should try playable games for Play! core also.

1 Like

Hmm, ok, well I only have Gradius V PS2 ROM available for testing (I dumped it from disc myself as it was the only PS2 game I own which is on CD and the RA disc dump function doesn’t seem to yet be able to rip PS2 dvd game discs, not for me, at least); I can’t see Gradius V in that list, however there is a video on the Play! blogpost in my first post which seems to show this game running on the core?

Also, not convinced the problem is down to the game being loaded itself, as I can’t even get that far; any other core I try to load under Load Core option immediately shows in the bottom left of the RA menu, without the need to even go near any game content. Play! is the only core to just back out to main menu and return ‘No Core’.

Incidentally, I just sent the Play! dll to the same friend I mentioned in my 2nd post who previously sent me the MAME 2016 core dll; he’s just tested my Play! dll and see the same behaviour, the core shows up in the list of cores but it will not load.

I tried the Play! core on Linux x86_64 and it is working but I had to add libcurl-gnutls.so.4 and libGLEW.so.2.1.so specifically.

You may try to run this tool to check the dependency ?

1 Like

Thanks again man, but I’m no dev and “libcurl-gnutls.so.4 and libGLEW.so.2.1.so” is like a different lingo for me :smiley: Don’t know much about libraries and dependencies, so whilst I could probably get as far as running that CLI / GUI tool, I really wouldn’t know what I’d be looking at / for anyway!

Happy to post up my APU / laptop specs if that would help; whilst far from an ultrabook, it isn’t exactly a total slouch either. I was wondering whether upping the 4gb inbuilt with another 4GB module to go dual channel RAM might help but it’s new, so I don’t really want to open it up and start tinkering with the hardware just yet.

Stumbled across this thread; as I already had 2017 - 2019, I thought I’d try installing the remaining runtimes sequentially from 2013 back to 2005, rebooting after each one but that didn’t work out either :man_shrugging:

1 Like

The Play! libretro core is now available in the online updater.

I could make some test on Win10 and it is working.

So you should be good to go :wink:

Grrrrrr! Still no change for me tho :face_with_symbols_over_mouth:

I updated databases, core info files and restarted RA after downloading the core too…

FML (F*** My Lakka :smile: )

I found the PSCX2 Core Here:

Though not been Updated since 31st of October last year

@3miliooo I thought you were on Windows ?

@DaveTheMan1985 yes this is the original port from @aliaspider but it has been merged to libretro repository. It is not yet published though.

1 Like

@gouchi - yes, I am on Win10 64bit as per my 4th post; ignore the Lakka comment, I was just being silly!

@DaveTheMan1985 - Thanks for this, unlike Play! I think I need PS2 BIOS for PCSX2 which I don’t have at the mo and which I don’t think are distributed with this download.

I dropped the PCSX2 core into my cores folder all the same however and was interested to see that it exhibits the exact same behaviour under Load Core option as Play! core does for me: it’s visible but just backs out to Main Menu without error and refuses to load (returns No Core). Rules out problem with the cores then, surely? Must be something to do with my setup still, unrelated to runtimes and OpenGL :man_shrugging:

@Gouchi when will the Libretro coming out for PCSX2 ?