Please show off what crt shaders can do!

Another ultra fast shader, a combination of plain scanline.glsl with a Gray-White mask, Bloom and Gamma. And it still runs 60fps at crappy netbook with gma3600 at 768p. Because why not? Some people may find it useful. I believe the image can be really good (especially at 1080p) for what it requires to run.


crt-geom with some tweaking and gtu-pass2 for luma control.


Another one, fakelottes with: all masks from Guest.r-Dr.Venom (glsl) added, mask size 1 or 2, contrast, bloom. Not bad i say. Still wanted to add a simple horizontal sharpness too. Not bad as it is, and playing with contrast really enchances image sometimes.


A little tweaking of an old shader, crt-hyllian-fast. There was an old cg2glsl messy code roaming around on the internet without any options or mask, so i took it, cleaned it to be readable and added a dotmask and some options.


Hi sonkun,

I like your pictures so much, that I wanted to try your preset out in Retroarch. Unfortunately it gives me an error “retroarch failed to apply shader preset”.

I just copied a Slang Preset and with the text editor I replaced all lines with the text lines you put here.

All other CRT shader presets are working fine btw.

Do you have any suggestion ?

Thank you.

The first thing I would suggest is to make sure you got the latest guest shader posted here:

Everytime I download a new guest shader update I go inside the folders shaders_slang>crt and replace the 4 shaders’ crt-guest-advanced-fast, crt-guest-advanced-fastest, crt-guest-advanced-hires and crt-guest-advanced with the updated files from the link I posted. Don’t just copy them over, delete those old shader files before copying over the new ones from the update folder. Then from there proceed to the folders’ shaders>guest. In here go inside the “advanced” folder, delete everything in there and copy over the files from the “advanced” folder from the link, then go to the “fast” folder and do the same there. After that then fire up my shader preset and everything should just work. Let me know how it turns out.

Thank you for your quick response. I did it exactly like this now, but still doesnt work.

After I replaced all the files correctly like you mentioned and finally edit (replacing) the text lines in the “crt-guest-advanced” slang file, it will not be accepted by Retroach and fails to load the shader :frowning:

Try this, delete your whole shaders_slang folder, open Retroarch and update your slang shaders so that you have fresh unedited shaders to work with. Then try all the steps again from my previous post. Don’t edit any files in any of the folders or anything from the files in the link, when you copy my preset use a fresh blank .slang file to put my shader preset into then place it right into your shaders folder then try to load it up again. See if that works

I did all the steps you mentioned and then created a fresh .slangp file (called it 1.slangp) and inserted the text from your preset. Then I choose the 1.slangp shader and it still fails to load in Mame. Do you think there is anything else I can try ?

Are you using the vulkan driver?

yes, also tried d12 before. Both the same.

Yeah, now I’m at a loss. Maybe one of the guys here like @hunterk can help you. This is the first time someone has mentioned this issue to me. I’m not sure what else could be causing the problem

BTW, i run a Notebook with a Nvidia GeForce MX150 graphics card. But that shouldnt be a problem, because all other CRT Presets work fine. The original CRT Guest Advanced shader works too. But I really like your preset, it would be sad if I cant try it out. Maybe, as you said, wait for hunterk. He has much experience with Retroarch and maybe knows where the bunny lies in the pepper :smiley: But thank you for trying to help.

1 Like

That’s strange. My preset is a mixed shader as well, I have the “grade” and “crtsim” shaders mixed in with my preset. That still shouldn’t be a problem though

1 Like

Is your RetroArch version current?

1 Like

I will try it tomorrow with my home PC which has a Geforce RTX 3060. If its not going to work I will do a step by step video and maybe you can watch it and tell me if there is something wrong with the procedure.

1 Like

That’s right, I forgot to ask what version of Retroarch you’re using, that could be the problem if you’re using a old version

1 Like

Yes, I just downloaded the newest build.

1 Like

Thank you and have a good night. See you tomorrow hopefully.

1 Like

Hi sonkun,

even with my home PC it does not work. I just made the video, where you can see how I copied the files etc.:

And here is another video, where you can see what happens in Retroarch:

As you can see your shader preset fails to load, while the others are working fine.

Maybe you could upload your preset .slangp file, so I can see if that works.

1 Like