PPSSPP core 1.11 seems broken

I’m testing the latest PPSSPP core and there’s something wrong with it.

First, the fix in Outrun (that shows reflections on the cars) is fixed in the standalone but not in the core.

Also, i tried Ghost & Goblins and there’s a regression, everything turns black when the first enemies appear. This doesn’t happen in the standalone.


Yeah Ai service is also broken on the core. While using Ai service while playing final fantasy tactics war of the lions, the game crashes. Particularly at the beginning of the game while inside the church.

I managed to fix my issues.

Updating the core itself isn’t enough, you also have to make sure all the files in the system/ppsspp folder are up to date. Mine were unchanged for a couple of years, which caused so many problems.

1 Like

I’m having similar issues with the latest PPSSPP core on my 4K Fire TV stick, but it has very rarely loaded from within RetroArch. I’ve tried everything in this thread, but nothing seems to help. It’s just strange, because I’ve seen it run.

Does anyone have a backup core of version 1.11-1?

Current (1.11-2) has a frame pacing issue. I’d like to test the previous one until a newer version gets fixed.

Thanks in advance.