PPSSPP - Jumbled Graphics - can't find the cause


#1

I’ve been having a headache with the PPSSPP core as long as I’ve used RetroArch. It refuses to co-operate with me.

I can load the core just fine, and load the game just fine… but then… THIS happens:

Oh, and here’s the log for this BTW… https://pastebin.com/pQ9kMnzC

So what happens is, I will load one of the Tekken titles for PSP, and get through the menus and pick my character, and it shows the fight card… and it starts to play the level. You see the fighter intros in 3D and all… and then WHAM this crazy graphics jumble occurs. It even completely freeze-crashes RA, so that log? it just ends abruptly.

Now here’s the REAL KICKER - After the D3D11 upgrade in 1.7.2 of RA or so, this problem had completely disappeared for me. yaaaay. I even have that install in another folder and it runs beautifully.

Except I did a fresh install of 1.7.3 because of some other issues, and now it’s back.

Problem is, even copying the exact same settings from the working version over does not fix the problem. The settings, the core overrides, EVERYTHING. I even copied the core .dll I was using over…

I went through every setting I could think of side-by-side with both versions running and it looks identical to me! Vulkan, D3D, OpenGL - they all give me this result.

I’m about to pull my hair out with this problem, because I know it’s something incredibly stupid that I’m not seeing.

Someone out there has got to have an answer for this :frowning: Please help me…


#2

I have had Problems with it but I just use the WIndows outside of Retroarch for Best Performance


#3

So, I know this post is old… but I’m STILL having this problem with PPSSPP. Has nobody really run into this before? I noticed that if I run it in a window these graphical glitches actually appear all over the screen and after a second my entire device driver resets - which is WILD.

Anybody? Any thoughts?


#4

According to your latest reply, I would bet for graphics driver problem. I would try updating gfx card drivers.

Good luck.


#5

I thought about that too, but I’ve got the latest AMD Radeon Drivers :frowning: - I just still can’t get my head wrapped around it working in 1.7.2 out of nowhere, and then never again.

I also don’t experience this with any other game, or program, or anything - and I’ve thrown every game you can imagine at this, emulation or modern or otherwise.


#6

Those artifacts make me think about an overclocked video card, could it be your case?


#7

Right!? That’s exactly what it looks like! I def don’t have it overclocked though, my poorly designed computer case has thermal issues so I keep everything at stock. Except the fans, those I run pretty hard.