Problems with controls "juyao dual arcade"


#21

Hi,

It seems you need to append to the cmdlineto get the 2 players working :

 usbhid.quirks=0x314:0x328:0x040

#22

Hello, How do I edit the cmdline? I connect with Putty

Thank you


#23

On which platform are you running ? It is written in the documentation how to do it, you need to use for example nano editor (shortcut CTRL+O to save, CTRL+W to search, CTRL+X to quit).


#24

I am working on PC, then i need modify syslinux.cfg, it is right?


#25

Yes, you are right.


#26

Hello,

I have followed the instructions to open and modify syslinux.cfg, but I am surprised that when I opened the file it was empty, I did not have any line of text. I have modified it with the command line that you put “usbhid.quirks = 0x314: 0x328: 0x040” but it has not done anything, it continues the same.

Thank you very much!


#27

The file syslinux.cfg should not be empty. What did you type to edit the file ?


#28

Hello,

mount -o remount,rw /flash

nano /flash/syslinux.cfg


#29

Hi. For you to have more information, I paste here the content of the file / storage / joypad / D_R_M JUYAO Dual Arcade.cfg

input_driver = “udev” input_device = “D_R_M JUYAO Dual Arcade” input_vendor_id = “788” input_product_id = “808” input_b_btn = “1” input_y_btn = “0” input_up_axis = “-1” input_down_axis = “+1” input_left_axis = “-0” input_right_axis = “+0” input_a_btn = “3” input_x_btn = “2” input_select_btn = “11” input_start_btn = “12”

And that I configured the controls for 2 players

Thank!


#30

Can you try with latest nightly in live mode and then edit syslinux.cfg?


#31

Hi. I’ll try what you tell me, but until the return of my vacation I can not do it. thank you very much


#32

Hello,

I already tried the Live version and adding at the beginning the line “usbhid.quirks = 0x314: 0x328: 0x040” works me correctly.

So I have done a new installation of Lakka and it turns out that the file syslinux.cfg is empty, but that does not exist directly …

Any idea where the problem might be?

Thank you so much!!


#33

Hello,

It seems that I have already solved it. What I have done is that when performing a new installation, in the boot menu where you choose Installation or Live, I select Installation but first I give the TAB, and I enter the line “usbhid.quirks = 0x314: 0x328: 0x040”.

Once Lakka is installed, I can now enter the console and re-edit the file, which now appears.

As a curiosity, indicate that the following message appears on the screen “100%: D_R_M JUYAO DUAL ARCADE (788/808) not configured”

But it still works perfectly.

Thank you!


#34

Hi,

So when you add “usbhid.quirks = 0x314: 0x328: 0x040” , it allows you to map the 2 players. That is a great news !

I don’t know why you have the message as you succeed to bind both player now, surely because of the usbhid.quirks ?


#35

Hi, what did you exactaly do? I tried this and I got it working in Live mode (massive thanks for that!). In the installed mode however I see no results :(.

When I’m in the bootloader of Lakka (loaded from a USB device) I type “live usbhid.quirks=0x…”. This works perfectly fine. When I type “installer usbhid.quirks=0x…” I can install Lakka as normal.

When I try to map my buttons Lakka still sees the controller as one. When I than try to access the command line via Putty, I also still don’t see the syslinux.cfg file.

Any idea?


#36

Hello!

I have the same problem. I tried everything as described above! System Ubuntu 18.04.1 LTS - minimal installation(it is important), kernel 4.15 Joy works with emullationstation (2 pads are visible) but unfortunately does not work in the game :frowning:

When i use standard Ubuntu installation with gnome windows manager - Joy works, everything is ok. But when i use minimal installation then i have a problem (emulationstation init - .xinitrc) At the beginning joy does not work also in emulationstation. When i put an option into es_settings.cfg bool BackgroundJoystickInput" value=“true” and then joy works into emulationstation only but still does not work in the game.