Problems with Reicast and Beetle_Saturn on new PC


#1

My build is on an external Hard Drive, which I’ve used to plug into a number of different machines. Usually the only problem I run into is sometimes DX9 isn’t installed on someone’s PC…

With this new PC I have though, I’m having 2 odd issues; one with each of these cores.

With Beetle_Saturn, the games will be running great, fullspeed. However, if I open up the RetroArch menu and then go back to the game everything is choppy and slow. I’ve tried using all the available menu drivers (rgui, xmb, ozone, etc) and no change there. I’ve also tried disabling vsync and enabling Threaded Video.

Toggling Threaded Video, either on or off - doesn’t matter which, will fix the problem but only until I open the menu. To kind of clarify, it doesn’t matter what threaded video is set to opening the menu will still cause the issue, but the act of toggling that feature fixes it. I’m guessing it reloads a video driver or something.

As for Reicast, when I start a game it either insta-crashes, or I see the “Game Remaps Enabled” text and it then crashes, or sometimes it will freeze video at that text, and in the background I can hear the BIOS audio playing… but then it crashes again.

Hardware Context is set to ‘on’.

Here’s the stats of this PC for reference:

  • CPU: Intel i5-7500 3.4Ghz
  • RAM: 32GB DDR4
  • GPU: Onboard Intel HD Graphics 630

#2

For Saturn, try enabling triple buffering in the video driver.