Px68k core changes original .dim files (bug?)

The Px68k (Sharp X68000) core is writing to every .dim that’s loaded up.

The .dim files I have are originally 1,233 KB, but after being opened in the core they become 1,361 KB. This happens to every .dim file I’ve tried, and they all result in the same size difference.

I tried this with a .zip as well and it resulted in a changed file that couldn’t be used again. The .dim files can be used after the alteration.

To see if this happens in other emulators, i ran files through the standalone xm6 g emulator and didn’t see any changes to the original files.

I don’t like the idea that a core is altering the original rom file, as preserving the original verified rom is important to me.

Is anyone aware of this or have any thoughts? I run most of my systems through Retroarch because I love the CRT shaders. I don’t think xm6 g supports shaders so I would like to stick with the Px68k core if possible.

Thank you!

1 Like

It also happens to me. Every zip becomes 1232kb and its corrupted.