RA insta-crashes when using Vulkan driver. Laptop RTX 2070 (optimus)

Hey guys! RA 1.10.3 from PPA insta-crashes on my laptop when I set the graphics driver to Vulkan.

Here’s what I get in the terminal:

[email protected]:~$ retroarch
MESA-INTEL: warning: Performance support disabled, consider sysctl dev.i915.perf_stream_paranoid=0

X Error of failed request:  BadMatch (invalid parameter attributes)
  Major opcode of failed request:  149 ()
  Minor opcode of failed request:  4
  Serial number of failed request:  77
  Current serial number in output stream:  83

RA log: https://pastebin.com/uvn7kQKJ

It looks like it’s trying to run on the measly Intel chip rather than the proper Nvidia card. I have no idea how to change that. But I can say this much, when trying to run vkcube, all I get is a black window (https://paste.pics/HN98F) and I have to Ctrl+C out of it from the terminal.

My system info: https://termbin.com/uuga

Any help would be greatly appreciated!

Linux doesnt have native support for optimus enabled hardware, yuo need to install bumblebee

https://wiki.archlinux.org/title/bumblebee

Hope this helps.

1 Like

Hey @cuyo01, thanks for your response! Strange, I thought this hasn’t been true for years. I remember Nvidia drivers adding proper Optimus support way back when I had my previous laptop, so I’d say, something like 2017 or so?

Also, with the Steam Deck taking off and people using Wine and Proton to play video games through Vulkan for years even before that, I’d expect everybody to be shouting from the rooftops if Vulkan didn’t work on Optimus enabled hardware? Am I missing something?

I checked and it seems the Bumblebee project has been abandoned for quite a while. I’m gonna do some more digging.

One thing that throws me off is that RA isn’t even trying to select the Nvidia chip:

[INFO] [Vulkan]: Found GPU at index 0: "Intel(R) UHD Graphics 630 (CFL GT2)".
[INFO] [Vulkan]: Found GPU at index 1: "llvmpipe (LLVM 12.0.0, 256 bits)".
[INFO] [Vulkan]: Found GPU at index 2: "NVIDIA GeForce RTX 2070".
[INFO] [Vulkan]: Using GPU index 0.

Is there a way to force it to use the GPU at index 2?

With “Show Advanced Settings-Enabled”

Settings>Video>Output>GPU Index

Ha! That did it!! I found the setting in retroarch.cfg and after I changed it, it launched on my laptop using Vulkan. Thanks so much for the pointer.