RA: PCSX ReARMed crashing on Final Fantasy 7 - ios 9.35

Hi everyone. I am using latest RA (v 1.9.0, built on 17 Jan 2021) on an iPad mini with iOS 9.3.5 with Phoenix JB. I am trying to run Final Fantasy VII but unfortunately it keeps randomly crashing on “scene changes”, i.e.

  • when entering a battle, sometimes crash;
  • when exiting a battle, sometimes crash;
  • when changing from on scenario to another, sometimes crash.

I’m starting the game from the beginning and I can’t play for more than 2 minutes before a crash occours.

All bios present and recongized by RA (scph5500, scph5501, scph5502).

I know this must be something specific to the core I am using (the only one I have available: PCSX ReARMed (r22 d56340b - which I also the latest) but I was wondering if someone has any insight on this problem.

I enabled the log to file in RA with “debug” sensitivity, they get created but with no content (0 bytes files) so I am completely lost.

Thank you!!!

@AfonsoH As one of the options: try deleting scph5500, scph5501, scph5502 BIOS and putting only scph7001(don’t worry, the core will find it without renaming it).

1 Like

@AfonsoH I compiled another version dating back from february 2020 to test, can you update the core and report back?

1 Like

Thanks for quick reply. Tried this but it is the same (in the US version of FF7; tried also with EU version and it crashes immediately before entering the “New game / continue” screen.

Sorry, not sure how to do that! Can I select the version directlly in RA?

@AfonsoH Just update your cores in the Online Updater

Oh sorry. I though I had to downgrade to a version from 2020. Just updated the core, now it sais ReARMed (r22) instead of ReARMed (r22 d56340b). Using scph7001 as suggested by @dagazik and both EU and USA versions crash before entering the “new game / continue” screen. Will try with default 5500,5501 and 5502.

EDIT: tried with 5500,5501 and 5502, but same crashes. Maybe its a hardware problem (to weak to run)?

@AfonsoH No, your device has enough RAM and GPU performance - problem in software.

We with @Weedy_Weed_Smoker testing support for the 1st generation iPad and even it runs all games at full speed with 50% load: https://www.youtube.com/watch?v=W3yJ9tax5-8

1 Like

Good to know! Tell me if I can help debug it somehow. But I can’t seem to get the logs working (log files are created but with 0 bytes - no content)

1 Like

@AfonsoH This is just a guess so far, we are trying to find the reason in this thread: Archive of RetroArch for iOS 5.1.1?

It seems that the new versions of the ReARMed do not work well with memory on 32-bit devices (freezes occur at the time of contacting the CD-ROM) and as a solution we are looking for an earlier version.

Please check this version of the core (manually replacing the current one in the core folder / should work slowly but steadily): https://github.com/laeryn/libretro-ios-cores/raw/master/pcsx_rearmed_interpreter_libretro_ios.dylib

Please tell us what result you got on iOS 9 :slightly_smiling_face:

Thanks. I can confirm that no crashes occour (after patiently waiting for the intro cinematic to end, because you are also right, it became a lot slower). Unfortunately like this is unplayable :slight_smile:

Now that you mention it, I recall doing something in CMRae Rally 2, which was to change to the interpreter during changes and enabling dynarec on the race. Guess the pure interpreter is able to render things nicely, whereas dynarec fails sometimes when accessing the cd-rom.

1 Like

@AfonsoH I uploaded a new test version from jul 2018, please try to update and report your experience!

@Weedy_Weed_Smoker I tested it. Your build of ReARMed r22 4adc2c29 from jul 2018 - freezes not saved and also slows. :frowning_face:

Tested as well. Confirmed very slow, but no crash on FF7 for a few minutes.

Just a related question: although not ideal, is there any place on the internet where one can access a revision history of the PCSX ReARMed cores? It is a long shot, I think, but maybe one could find a specific revision that worked well with a specific game and use it. Just a thought! (and I have not said it yet, but a big THANK YOU for all the efforts placed on libretro, retroarch, and all the cores development and compiling for so many platforms).

@AfonsoH It seems that at the moment there is no such place. Before, old versions of core ReARMed could be found on the official server, but after it was recently hacked and all the data destroyed, only the current builds are there. :angry:

In order for the core to work, it must fulfill several conditions:

  • Be compatible with processor instructions(in our case ARMv7).
  • Be compatible with the RetroArch 1.9.0 working rules.
  • Be compatible with the ios version.

You can try this: https://github.com/laeryn/libretro-ios-cores/blob/master/pcsx_rearmed_libretro_ios.dylib In my case, this bild caused the application to crash, but in your case it may work(since you have a more new version of ios).

Please tell us what result you got on iOS 9!

Oh that’s unfortunate :frowning: Thanks for the link. I tried it (the core is identified as r22 only). Speed is great, loaded without any problem. AND just played for 5minutes with fastforward always on and NO crashes! THANKS! The only thing I’ve noticed is that the notice that used to appear right after loading the content (something like CD 1/3 loaded - since I tried a multi-cd rom and loaded it with an m3u file) didnt appear. So not sure if this build is compatible with multi-discs?

EDIT: going to menu > home > quick menu > Disc control > eject disk > current disk index and I can see that 3 discs were loaded. But I guess that checking if it really works willl make me have to get past cd1 altogether :sweat_smile:


1 Like

@AfonsoH I updated the buildbot with a version from 2016 that should be working fine too! (just a little more recent than the link…)

You can update your core now! (And report back if everything’s working fine…)

1 Like

Thanks! Just tested it (r22) and I can confirm that no crashing occours.

1 Like

@AfonsoH That’s great news! Maybe you can add a (Resolved) before the title of your post now…

1 Like