Regression on the latest Flycast core

Previously I used naomi_boot.bin as BIOS file. After I updated RetroArch and Flycast core to the latest, all NAOMI and Atomiswave converted to NAOMI games can not be loaded anymore. So I placed NAOMI.ZIP as BIOS file. Some games can now be successfully loaded, some still have the following problems.

For Atomiswave converted to NAOMI games in bin/lst format, some SNK games now run like a snail, including Metal Slug 6, KOF XI, KOF NW, etc. Previously Metal Slug 6 is totally OK. Atomiswave games in zip format run normally with the lasts Flycast core.

For NAOMI games, now some games now promote “ERROR 2. THIS GAME IS NOT ACCEPTABLE BY MAIN BOARD”, such as DOA2 Millennium and Street Fighter Alpha 3 Upper. Previously these games run totally fine with naomi_boot.bin alone.

Even I installed the old Flycast 0.1 8193d58 core back, I still sense performance regression. I remember previously DOA2 Millennium can run in full speed on my Qualcomm 821 phone, now it often lags on the same phone.

Hope these issues can be fixed soon. Thank you very much.

1 Like

Please use mameset roms in zip file format. Same for Atomiswave roms with the corresponding BIOS awbios.zip.

Atomiswave to Naomi converted roms are no longer supported.

2 Likes

I can’t run rom atomiswave on flycast new update !:sob::sob::sob:

What is the reason behind this choice? It can’t be speed or compatibility, as all the converted games work flawlesly in previous core v.

Because real Atomiswave emulation is a much cleaner way to do it and makes future AW/specific compatibility improvements possible I would guess.

bye Michael

For me, with the latest flycast core, all my atomiswave rom (zip format) can’t run ! i have the awbios.zip in the right folder but when i launch a rom, i go back to the shield menu (retroarch crash). The naomi games works but atomiswave won’t run (the runed before the flycast core update) any idea ?

Your awbios.zip must come from mame otherwise it won’t work, pay attention to the file sizes.

firmware_count = 8
firmware0_desc = "dc/dc_boot.bin (Dreamcast BIOS)"
firmware0_path = "dc/dc_boot.bin"
firmware0_opt = "true"
firmware1_desc = "dc/dc_flash.bin (Date/Time/Language)"
firmware1_path = "dc/dc_flash.bin"
firmware1_opt = "true"
firmware2_desc = "dc/naomi.zip (Naomi Bios from MAME)"
firmware2_path = "dc/naomi.zip"
firmware2_opt  = "true"
firmware3_desc = "dc/hod2bios.zip (Naomi The House of the Dead 2 Bios from MAME)"
firmware3_path = "dc/hod2bios.zip"
firmware3_opt  = "true"
firmware4_desc = "dc/f355dlx.zip (Naomi Ferrari F355 Challenge deluxe Bios from MAME)"
firmware4_path = "dc/f355dlx.zip"
firmware4_opt  = "true"
firmware5_desc = "dc/f355bios.zip (Naomi Ferrari F355 Challenge twin/deluxe Bios from MAME)"
firmware5_path = "dc/f355bios.zip"
firmware5_opt  = "true"
firmware6_desc = "dc/airlbios.zip (Naomi Airline Pilots deluxe Bios from MAME)"
firmware6_path = "dc/airlbios.zip"
firmware6_opt  = "true"
firmware7_desc = "dc/awbios.zip (Atomiswave BIOS from MAME)"
firmware7_path = "dc/awbios.zip"
firmware7_opt  = "true"

Metal slug 6 , kof xi , neowave so very lag, zip bios no good

I also have extreme lag with King of Fighters neowave, King of Fighters XI and NeoGeo Battle Colliseum on my OnePlus 7 (that plays any other Dreamcast and Naomi/Atomiswave perfectly).

Also, strange issue, Fist of the North Star intro and between fights screens are at 30 fps (with perfectly synched audio), while the actual fights are 60.

Everytime i try to use a mame Atomiswave zip, after i Load Core and attempt to Load Content (the .zip) it takes me back to the cores menu, where i have to choose a core but Flycast is never there.When loading .lst or .dat games i never had an issue like this…only with Atomiswave zips from mame. If i unzip the files and Load the file that allows to be loaded, i always get a “game not accepted by the board Error1” message, after the Naomi Logo

1 Like

RaduNastase is right. Got Naomi working, but they had to be in .dat format, and even now not all run from the few i could grab. Cartridges dont work no matter what i try. Atomiswave doesnt work at all,much too slow, although everything is done here like flyinghead meant. Yes tried the mame rom too.

Oops… Made my ritual lag test and waited. Sadly naomi suffers also like dreamcast from hiccups, which frag my gamefeeling and made thick crocodiletears run. Btw. what i play runs correct (zero lag or issue) or i leave it, hoping for fixing. Well, dreamcast looked indeed extremely promising, but fails my ritual. Interestingly, the 40 mb ikaruga hiccups like the 1 gb roms, so there could be hope to play in excellence like ps1 (in retroarch ra 32 pcsxrearmed zero lag or stuff).

I would really like to know how the chances are for the dreamcast, like the saturn to reach a perfect state like ps1 in retroarch, on a snapdragon 845.

To say the last thing:

No, capcom vs snk 2 doesnt run perfectly yet no matter what platform. i know theres people who cant stop playing this game.

:sob:

What does not work well in this game for you man? Both Dreamcast and Naomi versions of CVS2 (and CVS1, aside from the old “KO sign” small visual bug) work almost perfectly in my OnePlus7 (and should also work on a 845). The only issue i find with Flycast is that the video sync is not 100% perfect. Randomly the fps would “drop” from 60 to 59.8 which results in a very small stutter, only noticeable in menus that have scrolling animations/text. This is not related to performance in any way, it’s either a Retroarch issue with Vsync on mobiles (fbneo has the same issue, though mame does not) or a core related issue.

And i say its got hiccups brother ! Runs seemingly perfect on s845… Yea until you put it to the test, man. Meant h.i.c.c.u.p.s !

Runs fine … but there it is … if you have a close eye on it ! Killed ma gamefeelin an made thick crockodiletears roll ! And everything i play / own on my beloved android runs in excellence (means perfect, no lag,stutter,audiocraggling or so) with optional netplay or flas off my handy.

Btw these stutters dont go away theyre persistent so no chance for a cachingbug.

…means our story: Tearing in my phone, but lag in yours ? Yeah that is technic. But i do not believe that at all.

Wonder if the old reicast core did better ?

And yes, k.o. -ed all settings. Hiccups.

Got amiga and c64 rollin like butter btw.

But the netplay freezes the cores so doesnt work on them both :flushed::sob:

Lg G7 thinq

I don’t quite understand you (my fault probably) but if you have video hiccups, be sure to have “Sync to exact framerate” DISABLED, Threaded Video (in Retroarch menu) DISABLED, AudioSync and VSync ON and, in core options (after you start the game) enable Threaded Rendering and Synchronous Rendering and set Framerate to normal. Also, games that don’t use polygons (CvS1, SfZero3, GGX) work well without Audio Sync.

no matter what combination of options like i said. Still hiccups on android. Theres no framerate option on android flycast btw. Needs to be fixed, hoping soon.

This is how it runs for me (watch in 60 fps). The video actually has a few extra stutters, but they are due to the recording. The actual game has a slight stutter when going to 59.8 fps. The loading/menu screens are pretty smooth regardless of the displayed fps.

Thank you,radu. Yeah,its luckily not my hardware,its the core,so i may hope for a fix. This is something worth to me !

To mention, these stutters are the same i have,even quite the same timing.

No problem man, my pleasure.

These stutters are honestly unoticeable, and i have a trained eye for this :wink: Best way to test it is in CVS1 when choosing the order of the fighers. Watch the scrolling text in the middle of the screen and there shoouldn’t be more than a small random stutter.

The audio/video sync issues was always the big thing that emulators tried to mitigate. No emu is 100% perfectly constant in this regard. Mame cores and FBN cores both have slight random deviations as well.

The only way to achieve 100% constant & perfect timing (though i bet there are “some” frame drops even there) is by using a display with an identical number of Hz that the game originaly runs at. Strangely, Galaxy Note 3 had a 59.6 Hz display and CPS2 games ran at native refresh no problem :slight_smile: Oneplus 7 has a 59.96 Hz display and all games must be synched to that speed, which is sure to present some degree of innacuracy, even if it’s just 1%.

I find that a game forced to run at above 60 hz (60.5), will sync much better to a 60 hz display, than a 59.5 Hz game.

Anyway, for the vast majority of 2D games in Flycast, Mame, Fbn, i recommend disabling AudioSync and seting an Output Rate of around 22000 Hz, to cut some highs and deal with the small audio clicks that may result (only Flycast has this small isuue).

Cheers

That sounds awful. I never had to do this in RetroArch.

It’s only Flycast that has s few frame pacing issues for me. AFAIK RetroArch changes the speed in order to sync with the screen. But with Flycast this doesn’t work it seems

I tried the Vulkan branch of Flycast and frame pacing is much improved there, at least for me. So in the (hopefully near) future, things should get better. Well, if your system supports vulkan, that is.

1 Like