Reicast core performance regression?


#1

I just updated from RetroArch 1.7.1 (reicast core 0.1 dated March 4, 2018). I was getting 60 FPS, but with RetroArch 1.7.5 (reicast core 0.1 01ffff9 dated November 18, 2018) I’m only getting about 45 FPS.

I haven’t really changed any settings from the defaults. Any ideas on what I should look at to see what is causing the dip in FPS?

Thanks!


#2

I believe there have been some performance regressions, but the biggest hit, IIRC, is the order-independent transparency (OIT).


#3

I’m an idiot. I had turned on Rewind for a different core. Sorry to bother.


#4

That was mschoneman’s mistake, but still yeah I too perceive it has become more demanding since regular and OIT were merged. Nothing like going from 60fps down to 45, but it’s there. It is now much more compatible though, so kudos to flyinghead. It’s an amazing core.


#5

There are a bunch of options that can help with speed :

  • threaded rendering (ON is faster)
  • synchronous rendering (ON is faster i think)
  • framerate (normal is faster i think)
  • alpha sorting (3 options, per-strip is the fastest)

#6

Synchronous Rendering avoids some frame skipping (depending on the platform speed) but should probably be set to off for best performance, although it shouldn’t matter too much.

framerate has no effect when Threaded Rendering is on and probably has negligible impact on perf when Threaded Rendering is off.

Other options that can help performance:

  • Decrease resolution
  • Disable Texture Upscaling
  • Disable Modifier Volumes
  • Enable Div Matching
  • Disable DSP

#7

Been running some tests out of curiosity. Actually, performance is slightly better than it was, so no regression whatsoever :slight_smile:

And the reason why I felt it ran slower is because I didn’t have DSP enabled premerge, and now I do. That is the setting that makes a difference for me (around 10fps), aside of course from alpha sorting