Remapping Wiimote(sideways) controls in Dolphin core

I’m having trouble remapping Wiimote controls in Dolphin core.

My setup is a several PS3 DualShock 3 controllers, masquerading as XboX 360 controllers, connected via BlueTooth over Windows 10.

By default, the WiiMote (Sideways) config =

  • = / :white_medium_square:
  • = /
  • Shake WiiMote = R2

but I want

  • = /
  • = /
  • Shake WiiMote = L2

I’ve tried in-menu changing this, but it doesn’t do anything. I’ve tried changing various config files, but every time I open RetroArch it overwrites it.

Also, I’m struggling to find out where RetroArch keeps its various Dolphin-based config files - can anyone tell me the definitive one to change? So far I’ve found:

  • C:\RETROARCHFOLDER\config\remaps\dolphin-emu\dolphin-emu.rmp
  • C:\RETROARCHFOLDER\config\remaps\dolphin-emu\wii.rmp
  • C:\SAVESTATEFOLDER\User\Config\WiimoteNew.cfg

I want this core-wide (rather than just for individual games), so every Wii game that defaults to WiiMote (Sideways) defers to my choice. Which config files do I need to change, what do I need to add to them, and how do I stop RetroArch from overwriting them?

For the record, the WiimoteNew.cfg file for standalone Dolphin uses the following (which I set it to):

Buttons/A = `Button X`
Buttons/B = `Button Y`
Buttons/1 = `Button A`
Buttons/2 = `Button B`
Shake/Z   = `Trigger L`

Yet RetroArch’s WiimoteNew.cfg file gets overriden each time with:

Buttons/A = A | `Libretro/0/Pointer:Pressed0`
Buttons/B = B
Buttons/1 = X
Buttons/2 = Y
Shake/Z   = R2

I’ve tried changing these latter values, but they get overridden. What do I need to do? Thanks!


One thing I can certify is the following: it’s not due to your PS3 controller masquerading as xbox360 controller.

I’m experiencing the same, with a xbox360 controller, I want to remap the 1&2 button and also the A&B button of the sideway remote controller at the core level, same as you.

Tried to change it on the game input menu, when going back to game it doesn’t catch my remaps. Tried then to save at the game level, and core level, doesn’t work either. Both also tested by exiting content and reloading it. Same also for retroarch. The game menu seems to keeps my bindings but they won’t apply in game.

EDIT : just tested remapping of gamecube controller in NGC game with the same core, no problem at all, my remaping are effective in the game. Seems to only happen on the wiimote(sidway) controller.

Thanks in advance for any feedback on this post.

Yeah, it’s definitely only Wiimote(Sideways) that is affected. All other configurations (GameCube, Wiimote, Controller Classic) seem fine. Just sideways Wiimote is impossible to alter, both through the GUI and config files.