Resident Evil 2 doesn't load on flycast

I already tried to force CE mode, change the bios, change de broadcast but the game still crash after the SEGA logo on boot.

I know about the specific core “flycast CE”, but it doesn’t exist anymore =/

I had the exact same problem… I was using verified gdi and bin. I heard they were switching to cue and bin so one day I went to and downloaded the zip of cue files. Once I copied the correct cue files and used them instead of the gdi it worked!

I hope it works for you too.

1 Like

It really works! But the CGI scenes are soo slow =/ But thanks for the help

Hello. I have the same problem and the game just wont load after the Sega logo on Flycast. I DUMPED MY OWN GAME, SINCE THAT’S THE ONLY LEGAL WAY TO GET IT and tried using cue file you mentioned from redumpORG but I only get an error message. I am wondering do I need to download full game files from redumpORG site somewhere but there is no link for full game download on site?

I am just not sure what to do now.

I hope you can help me.

Thank you in advance