Retroarch 1.6.0 for PS3 Released. PS3 is back again!


#34

Can’t seem to create playlists for my roms, the scan doesn’t give any output. Can someone give me a tutorial on how to create a playlist. I have my roms on USB HD in a dir called ROMS. I go to import content and scan the directory, for example the MAME subdir, there is a pause and then back to retroarch menu. I have also tried to scan the dir through the Load Content menu which has the same effect.


#35

That’s great news! I really need to check in on this thread more often. lol

What is the deal with using overlays/borders? Why can’t I get that to work?


#36

I don’t think overlays are hooked up. Not sure about that, but if they’re not working for you, it seems likely.


#37

I stand corrected, just loaded 1.6.3 and overlays ARE working!

I am super pumped about this because I had been banging my head against the wall trying to make them work. Folder search to make playlists is still NOT working for me though. It sits at 0% on the bottom of the screen and doesn’t budge. I tried loading the corresponding core for each folder, thinking maybe that had something to do with it, but no dice.

My recently played menu works though, so not a huge deal.


#38

Anyone knows where i could find 1.6.3 CEX verion? have been lokking around for a few days, but cant find it anywhere.


#39

Here is the CEX version: RetroArch 1.6.3 CEX

and here the ODE version: Retroarch 1.6.3 ODE

This version is better than 1.6.0 since prosystem core works again fully.

Recently (about 2 days ago) ngp core has been fixed and it is again working on ps3 after several years. Latest time i saw it working was on RA 1.0.0.3 if i remember good. Anyway i’ll build a little pkg including the fixed core in the next days, so ps3 users can enjoy again with it.


#40

thanks a lot for sharing this! i’ll surely enjoy this with my friends.


#41

the links dont work tho. both link are broken


#42

Retry again, the links should work now.


#43

its working now, much appreciated


#44

Here it’s the fixed core (neo geo pocket color) for cex and dex.

fixed ngp core for CEX

fixed ngp core for DEX

Just install the fix over RetroArch 1.6.3

Kudos to the libretro developer r-type for the fix (big endian issues).


#45

Ciao Ezio! Thanks a lot for all your hard work :slight_smile: After a lot of years I refurbished my broken PS3 and now I can test Retroarch on ODE.

I tried 1.6.3 ODE release on my Cobra ODE 5.1 with firmware 2.4 and OFW 4.55, but when I load the ISO from the backup manager it stuck with this error code:

“Si è verificato un errore durante l’operazione di avvio. (80010009)”


#46

Ciao lollo78 :smiley:

Thank you for reporting the issue, I’ll do a new ODE build and let you test it.

Unfortunately I haven’t ODE on my ps3, so i need the feedback from users to know what it works and what not.


#47

I’m here, ready to test it. See you soon with a new ODE link :wink:


#48

Try this one. retroarch.1.6.3.ode.ps3.fixed


#49

Always the same issue on startup: error 80010009


#50

oh. :frowning:

I need to see better when ode build worked (on retroarch 1.3.6 for example)

Anyway I guess it’s better that we wait for the next release since RetroArch 1.6.4 should be on the air.

Edit: Did you test 1.6.4 ODE available on the libretro server?


#51

Hi Ezio,

Is there a possbility that network connections and/or directory scanning will be supported in the future?

Thx for all you do for the community!


#52

Hi Ezio, good news. Just tried 1.6.4 ODE and It start without the previous error code. But all the GUI icons are missing: there is no possibility to download assets (missing voice into the menu?) and the other options inside Online Updater doesn’t work (“task failed” error). I have to test it (I just started it for now) but I think that all the issues could be manually fixed with a PC an USB drive and the Directory menu.


#53

@ donmega Network connections and directory scanning are targets to reach for the future development of retroarch on ps3, but i cannot tell you when they will be got.

@lollo78 online updater doesn’t woek yet on ps3, it’s related to network code which isn’t working. Gui icons are missing since assets aren’t included for some reason on retroarch 1.6.4 ode and cex. Anyway the issue has already been solved some days ago on the buildbot code, but there hasn’t been yet a fixed release. I could do this weekend whether nightly ps3 isn’t yet available.