Retroarch 1.8.5 Certain textures are black Mupen64Plus-Next

Using the Mupen64Plus-Next core on Retroarch 1.8.5 I am getting some black textures on Goldeneye & Super Smash Bros, there are probably more I haven’t found yet. Is there any settings I need to change to fix this? I am on iOS 13.4, iPhone SE jailed.

I believe this isnt just an apple problem. Ive asked around for awhile and found no answer. Mario golf is a big one, all courses are black. Thing is, in provenance another ios frontend with a mupen64plus core, everything works fine. I think it has something to do with gles?

I also have the same problem with my 13.3 jailbroken ipad mini 5. Conker’s bad fur day also has the same problem conker is almost all black but all the other textures are fine. I wonder if it is same on ios 12? @Trebrick What’s your ios version?

Having this same issues as well with no solution :frowning:

I couldn’t edit my post, but I’m running 1.8.6 on an iPhone 8 and having these issues, although it seem as others have stated, Provenance emu seems to work fine and doesn’t have these glitches in N64.

iPadOS 13.5 here and I’m seeing the same issues. Beetle Adventure Racing is where I first noticed, but it’s everywhere.

I’ve been having the same issue on my Apple TV 4K. Many textures in many games are black. I’m using weedy weed smoker 1.8.8. ipa.

I did a couple of tests: I unistalled weedy weed smoker ipa and installed the retroarch 1.8.8 build from Libretro official site on my iPad 6. The problem was solved: no more corrupted/black textures.

I reinstalled the weedy weed smoker 1.8.8 ipa on my iPad and the textures were again black. I fear that the issue might lie inside the weedy weed smoker ipa, as the “official” one seems to work without any issues.

Would it be possibile to fix the issue then?

Sadly, also none of the TVos ipas on the official libretro site contains the Mupen64 core, only weedy weed smoker ipa has it and as stated it has the black textures issue.

Above all, thank you very much @Weedy_Weed_Smoker, @jet082 and all of you guys for making N64 on ios possibile again and for your compiled versiones that you upload for us.

@jacka77 See if you can install the ios core on your appletv. Should work. I tried though and still get black in mario golf. Can u check that on your ipad

Ok, I did some additional tests. Here’s what I found.

I confirm that Mario Golf is still broken in both versions. Core version packed inside libretro official build is Mupen64 1.0 a7adaf2; core versione packed inside Weedy Weed Smoker ipa is 2.0.5 etc. It seems to me that both cores are broken in specifically different ways; let’s just say that “official” core 1.0 a7adaf2 seems a little less broken.

Rogue Squadron plays good and has no black textures issue in core 1.0, black textures appear in core 2.0.5. Goldeneye too: there are black textures only in the menu for core 1.0, black textures appear on enemies and objects on 2.0.5; Aerogauge renders good, no black textures in 1.0, black textures appear on vehicles on 2.0.5…

Was not able to install ios cores on tvos. Core wouldn’t load.

As 1.0 appears to be a little less broken, maybe it could be brought back to weedy weed smoker ipa?

@jacka77 Yah the ios core should work on tv if you drop the dylib in the modules directory. Does for me. And curious, are all the core options set the same for you between 1.0 and 2.0.5?

Hi @jacka77! (Hi @Trebrick too!)

I opened an issue in the GitHub repo… Hope this gets resolved eventually!

In the meantime, I think I will include the @jet082’s version that’s not plagued by “black texture issues” on my releases!


1 Like

@Weedy_Weed_Smoker thanks for that. Yah itd be great to make some headway on this issue. Seems odd that Provenance has a mupen core without these issues yet they are present on retroarchs core. One would think itd be the other way around.

1 Like

Thank you @Weedy_Weed_Smoker, you’re amazing!

1 Like

@jacka77 @Trebrick @toupee I just updated the mupen64plus next core on my buildbot, I will update the IPA soon with RetroArch 1.8.9 too!

@razor221 @TheNoLifeKing The setting you need for Conker’s Bad Fur Day is :

LOD Emulation -> False

@Weedy_Weed_Smoker thanks but seems to be no changes to mario golf at least. If it fixes things for others thats cool though. Do the official mupen build and jets have the same build number?

Thank you @Weedy_Weed_Smoker. I downloaded the updated cores from your buildbot, injected it in the modules directory and installed RA again on my Apple TV but the TVos mupen64 core fails to open on Apple TV.

Works good on the other hand on regular iOS (iPad 6).

@jacka77 I just updated mupen64plus next for both iOS and tvOS with versions I compiled myself, it should be working fine now for AppleTV!

BTW, why do you install the cores manually, isn’t the integrated update working for you? (If your AppleTV is not jailbroken, then I understand)…

If your AppleTV is jailbroken but the core downloader/updater is not working, it may be a permissions problem caused by manually installing cores in the first place… Just delete them and reinstall them with the core downloader!

1 Like

Now if we could just figure out what it is about mupen in that other ios emulator that doesnt show these glitches. Especially so i can get mario golf working lol EDIT: just reread you think its because of bad opengl es 3 implementation and that jet was working on something. yah hopefully can get this workin some day

1 Like

Thanks @Weedy_Weed_Smoker! Everything works fine now… Regarding your querstion, my Apple TV actually is not jailbroken at the moment. I used to have jailbreak on various devices I had in the past, but now I gotta admit that I don’t feel the urge anymore. I’ve been using appdb for a couple of years and it gives me the possibility to install emulators on my device, which was the main reason I was jailbreaking :slight_smile: Anyway, thanks again!!

1 Like

Thank you. How am I able to download the new version you’ve created the resolves the black box texture issue? On a non-jailbroken device adding cores manually always seems to fail for me and I can’t seem to alter the ipa by adding it in there as well. Am I missing something?