RetroArch 360 releases (v1.0.0.2)

RetroArch Xbox 360

This is the official forum thread of RetroArch 360. It will serve as a support thread and as a release thread.

This is a port of RetroArch to jailbroken / debug Xbox 360.

Cores currently supported:

  • Genesis Plus GX
  • Genesis Plus GX
  • SNES9x Next
  • VBA Next
  • NEStopia
  • FCEUmm
  • Mednafen PCE Fast
  • Mednafen NGP
  • Mednafen VB
  • Mednafen Wonderswan
  • Prboom
  • NX Engine (Cave Story)
  • Tyrquake
  • FInal Burn Alpha
  • Gambatte
  • MAME 2003 (0.78) NEW!

Downloads can be found at “the usual places”.

2 Likes

Hello, Just wanted to start by saying thank you for creating such a well equipped, solid front end. This thing has been working great so far for me. You just can’t ask for much more when it comes to an emu. Simple, intuitive menus and just the options that matter. It’s great!

After playing with it for the past few days and setting up several of the compatible cores on my 360, I came across just 2 issues. I might find another… but 2 small issues is nothing to complain about after seeing what RetroArch can do!

Issue 1 I found with Mednafen PCE Fast v0.9.28 (mednafen_pce_fast.xex) This same issue has been brought up in the Wii release thread twice for v0.9.8.4 as well; see here and I will post the other link in the next reply I make. When opening a PC Engine ROM, such as Adventure Island I will almost always have the game start up unresponsive to any user input on the controller (standard Xbox 360 controller) and the joystick stuck in the up position. It doesn’t matter what buttons you press on the controller. Nothing will stop the emulator from thinking the joystick is stuck in the up position. When it occurs I can still always press R3 (the right joystick button) and escape to the RetroArch menus. Once I do that, there is no scrolling or issues with the controller in these menus. But once you return to the game it is just the same as it was when you left it.

This occurs about 90% of the time. If it doesn’t occur immediately, it will get stuck in the up position less than a minute into gameplay. Testing this core with a SuperGrafx ROM, I got it to work for the first time, but the same issue re-surfaced partway into the games I tried (1941 - Counter Attack and Aldynes) I have tried the following with no luck: Disabled D-Pad Emulation in the controllers menu. Set as many of the controls to “No Button” as I could change. Ensured my SYSCARD3.PCE was in both the system folder and the folder where the ROMs reside. (Shouldn’t be necessary anyways from my experience so far… I just gave it a shot to see if it made any difference) Tried many different ROMs Tried issuing Resets from the Quick Menu

Issue 2 This is hardly important, but I found that I can’t change the assignments for certain buttons to what I’d like them to be set to. It would just be nice to be able to set some of the buttons to my personal preference on some games. For example; If I want to set RetroPad Button A to X or Y, I am unable to because they are not options in the list of possible buttons to assign. The same goes for trying to set RetroPad button X to hardware button A or B.

PC Engine would be cool to get figured out. If I knew more about how the controllers interfaced with RetroArch and in turn with the emulator modules, I would try my hand at helping… but my skills are pretty lacking.

Anyways, just figured I’d mention my findings. Meanwhile, I’m going to keep having fun with this thing! Thanks guys!

The other link to the PCE issue in the Wii thread: Click here.

Hello! I tweeted this question to @libretro a couple hours ago. I though I’d go through another avenue to see if the question could get answered. I’m using Retroach 0.9.8.4, libretro SNES9x Next v1.52.4 on the Xbox360. Is there a way to play 4 player games? Also, can the ps3 version of Retroarch use multi-tap support too? I certainly appreciate your work over the past several years Squarepusher on the ps3 emulators. Your Snes9x port is the best emu I’ve ever used and it auto-recognizes if the game has multi-tap support and it asks the user if they wanted to enable it. If this functionality isn’t yet in retroarch, hopefully til will be soon! Thanks!

Version 0.9.9 released.

Read these ‘release notes’ please -

  • (360) Removed shader system for this release - will be re-added in a future 0.9.9 point release. The main problem is that on Xbox 360, all our render targets need to fit inside 10MB of EDRAM - which is just pathetic if you want to have any FBO scaling options similar to what can be done on PS3. I’ll be looking at either tiled rendering or just implementing the same ‘hack’ I did before (where I forcibly set the maximum source framebuffer resolution at 512x512 for two-pass shaders and hoped nobody would notice so I could stay within the confines of the 10MB of EDRAM for render targets). For now, the PS3 port is way superior than the 360 port in the graphics stakes due to this 10MB EDRAM limitation for render targets.

Hopefully an alternative will be implemented by the time 0.9.9.1 rolls out.

  • Custom Ratio mode is currently broken. ‘Path Options’ is currently unimplemented.

I think there is an error on the lastest 0.9.9 release : when I launch it, it indicates retroarch 0.9.8 in a frozen window… I tried 0.9.8.4 -> it works so doesn’t comes from my xbox :p.

My mistake -somebody on #retroarch already alerted me to this fact. It was basically an ‘old version’ of RetroArch that got accidentally renamed to ‘0.9.9’.

I have since reuploaded the 360 version at ‘the usual places’ - so try again. Should work this time.

Hi ,it works better now with a real v0.9.9 :wink: Thanks for this incredible release !

some remarks :

  • It seems that zip files are not visible when you browse for rom (only uncompressed are visible)
  • When you browse, back button come back to main menu (Maybe that after redoing the controls of the Xbox 1, make a copy / paste?)
  • launch a rom with the wrong core crash (in a first time a popup message can be cool and fast to code to prevent an error, something like “you’re about to launch an .smc extension with an nxengine core , are you sure ? blablabla”
  • I think there is something stange in “input options”, for example on nestopia, try to inverse A and B buttons : you modify A, then you go to B settings and when you try to modify B, A is modified too.

Control input remapping is a big ‘WIP’ and hopefully we can fix that issue once and for all on all platforms with 0.9.9.1. We just need a decent standardized way of doing it.

‘The popup thing’ would be nagging but I guess with an optional ‘turn off nag message’ it could be tolerable.

I know about the Back button in the browser going back to main menu - this is how it’s currently programmed until I find a better way to do it. The menu code for 360 is totally different from RMenu/RGUI because I use MS’ XUI GUI system on 360.

Regarding ‘zips’ not showing up - I hadn’t thought about that when we removed the ‘zip’ extension from the cores’ allowed extensions lists - what I should do instead is forcibly add ‘zip’ as an allowable extension inside RMenu XUI. I will ram that through for 0.9.9.1 - thanks for catching that.

What about PCSX ReARMed support in xbox360 version? Available this?

Of course not, it would be useless on 360.

My dev Falcon 360 broke down today with RROD.

So I guess unfortunately 360 development stops here and now then as far as I’m concerned unless somebody can gift a replacement. I already paid through the nose for one back in 2011 and got a shit box in return that barely lasted 2 years (same with debug PS3) - not going to go through that again.

EDIT: It sucks too because I wanted to add back shader functionality and some more lovely stuff.

Can you get a 360 modded yourself, or would it have to be modded beforehand?

Depends how much hassle and money it is going to be to do the RGH hack - or whatever we need to do to get it modded. I really don’t want to sink a truckload of cash into this thing again and I’m not going to do so either - I already did that once for the community’s sake without so much as even begging for a single donation - not going to do that again.

Really, I just need a hacked 360 so that I can get back to development again. I really don’t want to have to bother with manually installing whatever RGH contraption is needed or having to buy that. If that could be done beforehand - that would be great.

I’m willing to pay for shipping at least - that’s as far as I want to go for the sake of keeping development going. I have not played on this thing since 2011 or so anyway so it’s not like it’s used for my amusement or whatever.

Would probably be a good time to just discontinue the port. The maintenance load is insane enough as-is.

If nobody will be willing to contribute or gift a replacement then I’m afraid I don’t see any other choice.

I’d like to make the 360 port better just for the record so the intent is certainly there - but no way am I going to give even more of my hard-earned cash to these XDK seller guys - they’d just give me the next worn-out warhorse again and it would last for another year before giving up the ghost.

I don’t want to come off as sounding cheap or anything, it’s just my finances are really terrible. I could probably get a new slim model from the store and send it if shipping doesn’t have too many problems, but then paying to also have it modded would hit me pretty hard.

If that new slim model is guaranteed to be exploitable with the RGH hack or some modchip or whatever - then that would definitely be a solution and you can leave the modding alone - I could take on the cost then of having it modded. We just need to be sure that this unit is hackable. I am not really up-to-date with 360s and their jailbreakability status.

Let me know through PM.

Just curious, reading through this thread makes retroarch360 seem close to end of development due to lack of hardware. Are we going to get a 0.9.9.1, at least to support zip and 7zip, fix the lack of ability to set rom path? Hopefully these are minor updates. I’m willing to be a beta tester.

Yes, the development 360 is still dead, and there is still no replacement.

A replacement RGH 360 unit costs 200 Euros over where I live (this is excluding shipping).

If people want to see this port alive again and be greatly expanded, you know what to do - I need either a guy gifting a 360 to me (with RGH) or some other means to eventually obtain the item in question. I have to walk a very strict line between sticking to our no monetary donations pledge AND being able to get a replacement for this thing in a way that I don’t get hit with tax / customs fees and whatnot - so to anyone who is serious and wants to support the project regarding me being out of a development 360 - do PM me.