Retroarch Crashing on Startup

I currently have switched from Linux Mint, which Retroarch was working just fine on and I had a lot of fun on it to Peppermint OS due to my computer needing all the RAM it can get. I love this distro quite a lot and prefer it over Mint. Though today I tried to install Retroarch, added the ppa and installed it along with all my prefered cores. Though upon starting it shows a bit of the XMB menu before freezing completely, not even killing the program will kill the window. Only way to get rid of the window is to restart the computer, this happened for both the stable and nightly builds so there is a problem with my OS most likely. Is there anything i’m doing wrong? A driver I’m missing or something else?

If the kernel has anything of note I’m running x86_64 Linux 4.8.0-41-generic

Try launching from a command line with --verbose to see if it tells you anything informative before it freezes. The first things to check would be trying it with menu_driver = “rgui” instead of “xmb”.

1 Like

This is the closest thing to a display driver I found in the log

RetroArch [INFO] :: Found menu display driver: “menu_display_gl”.

Sorry, I meant: open your retroarch.cfg (typically, it should be in ~/.config/retroarch/retroarch.cfg) and find the line “menu_driver” and change it from “xmb” to “rgui”

Nope, still doesn’t start.

alright, you’ll have to copy your verbose log somewhere like pastebin and then post a link here so we can take a look.

http://pastebin.com/d2J1b3UA

Here you go

That log looks okay… I wonder if you’d have any better luck building RetroArch for your system instead of using the PPA.

Unfortunately my computer’s eMMc drive bricked, so now I can’t boot anything from it. I appreciate the help though, if I get a new laptop I will most likely install something like MInt or Solus.

Hi I’m new here and new to linux (using linux lite distro). This exact same issue happens to me that Boured explained… I’m using a Toshiba L40 - 15G with Intel® Pentium® Dual-Core 2310, (1.46 GHz), 533 Mhz Front Side Bus, 1 MB level 2 cache, Intel® GL960 chipset with 1GB RAM.

I also have MAME, MESS and PCSX installed but I want RA so I can have all organized in one program.

Can anyone help? I’m not linux competent…but I installed everything has directed.

Thanks in advance

You can try using our AppImage package:

Just download it and then run chmod +x on it to make it executable. You’ll have to go into settings > directory and set up some things, like your core directory (making a ~/.config/retroarch/cores directory and selecting it would be good).

Can you go into detail on that, please? I also new to linux terminal/command line…it’s all so confusing… I’m using a 32 bits system isn’t that for 64bits?

Thank you

Yeah, it’s for 64-bits, and that CPU is 64-bit capable, so you really should switch to it (32-bit x86 is generally considered legacy at this point), but that’s neither here nor there.

If you were on a compatible system, you would download the appimage to somewhere (we’ll use your home directory, ~/ just for simplicity here), then open a terminal. It should default to your home directory, so no need to change directories, but if you did, you would type ‘cd /whatever/path’ to get there.

Once you’re in the same directory as your appimage, you just type: chmod +x name-of-program.appimage and it will make it executable. From then on, you can double-click it or run it from a terminal like this: ./name-of-program.appimage

Since I don’t know much about using the terminal and command lines I did like this:

  • Downloaded the file to Downloads folder

  • Right-click on it and click ’ Make file executable’

  • Go to Home folder and back to Downloads folder

  • It says now it’s executable

  • Right click on it and click Execute

  • A text file with this name appears displaying weird characters: �[email protected]@X�@[email protected]@@@@@��@@@@ (invalid encoding)

  • I click on it and it’s a blank text file…

That works, too. :slight_smile:

However, since it’s a 64-bit executable, it’s not really surprising that it didn’t work with your 32-bit OS.

I read this thread:

It’s for 64bits OS only. I’m running 32bits Linux Lite 3.2 I also have 32bits BIOS.

I wonder what can I do to make this work :frowning:

Upadate on this: I Manage to make RA work. The problem was vídeo driver I changed it to “sdl2” with the “rgui” menu driver.

I tested some cores like fb alfa, gameboy, gamegear, fuse, for what I tested these are working.

The problem is with PS1 cores. I can’t get them to work. I have the BIOS files on RA system dir. The roms load but after a while RA crash.

What could be the problem? Thanks or any assistance on this…

Are you running the beetle-psx-hw core? If so, try switching to the not-HW one. SDL2 may not be up to snuff with the GL support.

1 Like

I was using PCSX1, I changed to beetle-psx core asyou described and it worked! Thank you! However the sound is all crackled/cracked… I tried several audio drivers available and the least worse is tinyalsa, but sound still all cracked even when Sony bios sound starts!

I currently testing these games: Resident Evil (works) Resident Evil 2 (works) Oddworld - Abe’s Oddseye (works) Silent Hill (works) Medal of Honour (does not work I think it’s beacause it’s .mdf format and does not have .cue file) Metal Gear Solid - (Does not work the game loads but when the intro starts RA crashes) I’m using scph5501.bin bios. All games with sound problems.

Any tips for fixing sound issues and run Metal Gear Solid?

Thank you for your help!

Hmm, that likely indicates that your CPU isn’t up to the task of running that core. Many PS1 emulators, like ePSXe, have dynarecs that greatly decrease the CPU load. Unfortunately, we don’t have a dynarec for Beetle-PSX.