Linux RetroArch runtime for EVERY modern Distro with AppImage

I saw that there is no precompiled Linux executable for RetroArch. I guess it is because of the different Linux Dependencies. But there is a Programm called AppImage which solves the Dependencies problem. In Windows the dependencies are the *.dll files, Linux uses *.so. AppImage combines the Linux RetroArch executable with the required .so files in one Image.

RetroArch.AppImage (x64 Architecture only - no installation required, just make the AppImage file executable) download: ~46 MB How to make AppImage executable: right-click --> Properties --> and check “make executable” or by command line “chmod +x RetroArch_x86_64-1.3.4.AppImage”.

I hope i did not forgot to include an *.so file. Tested successfully on Debian 8 and Kubuntu 15.04. This is great for Linux users who cannot compile RetroArch for themselves.

EDIT: download the fixed version:

Oh, that’s interesting. We may want to start providing automated linux nightlies with this.

Ok, released this a bit too fast. Seems i have included some .so files which i shouldn’t. (Nvidia Driver issues and Alsa). It will take some time to fix this…

Nice, thanks :slight_smile: I plan on installing Ubuntu 16.04 on my tablet just to test the performance of RetroArch and KMS (as Lakka does not boot on 32-bit UEFI), this will allow me to test it on the LiveUSB making it far easier for me.

@lagonauta tell me if it works with LiveUSB and Ubuntu 16.04 when you’ve tested it. This one works on all my Systems with Sound and Nvidia Graphics card:

Ok - AppImage is more complicated then i thought, but it is doable. I soon will try to make an RetroArch AppImage based on ArchLinux packages. Collecting the correct .so files is time consuming. Don’t try the AppImages i’ve uploaded yet they probably won’t work.

After doing some research i finally found an official “excludelist” for .so files you shall not include into your AppImage. excludelist I compiled RetroArch on Ubuntu 14.04.4, i have not yet tested it on systems prior to this. I think for this AppImage i did everything right and now it is only about 7 MB in size.

Note for Developers - with “ldd ./retroarch” you can see on which .so files RetroArch depends. Don’t forget to make the file executable.

Loads up fine on Xenial (though I already have a working RA install, so YMMV). :slight_smile:

I guess you were surprised to get into your actual RetroArch setup. :slight_smile: (AppImage uses the same file structure for Applications) If it loads it should work.

Are you using deb package or tar.gz source to create AppImage ?

It’s a pitty that there is not much Documentation for AppImage.

Thats how i did it: I installed a Virtual Machine with QEMU (VirtualBox should also work) running Ubuntu 14.04.4. (because it did include my Nvidia Drivers when i did ldd ./retroarch on my main System) Then i compiled the Source Code of RetroArch 1.3.4 and i also compiled AppImage (to ensure compatibility with AppRun). Setup the “retroarch.desktop” file correct. And finally copy the .so files to /usr/lib and remove the .so files from the excludelist i mentioned before. (you can view my AppImage for file structure and retroarch.desktop with AppImageExtract) Build the AppImage with AppImageAssistant. (retroarch must be set executable in /usr/bin)

Don’t use the apt-appdir script - it does not work well - at least for me.

I found a script which copies all required .so files to a folder. cpld.bash --> And it’s a good idea to test the AppImage on several Distros which have a “live boot” option. It should run out of the box.

I hope to see an AppImage for RetroArch and for many other Apps too!

There is now an AppImage available from AppImage recipe you can test !

We are working to improve it and add all file which are necessary.

[QUOTE=gouchi;48203]There is now an AppImage available from AppImage recipe you can test !

We are working to improve it and add all file which are necessary.[/QUOTE]

I have tried the latest available AppImage, on Ubuntu 16.04 64b, and it seems to work great from the tests I made, and seems more up-to-date than the Ubuntu PPA. Performance seems as good, all cores I tried work fine and it uses my config from the PPA-installed version properly. In short, all good!

I use other tools packed in AppImages, such as Krita (an art tool), and can vouch for the simplicity and convenience of using AppImages to distribute complex software like this. Would love for Linux RetroArch point releases to be distributed in this fashion, would make it easy to stay up-to-date with a single download.

You can now use AppImageUpdate to get binary delta update !

For example, to update RetroArch-1.3.6+r444.glibc2.17-x86_64.AppImage

Just launch AppImageUpdate and select the AppImage package you want to update.

Or with the command line (you need to give a full path for the AppImage package) :

 ./AppImageUpdate-401.ge609d84-x86_64.AppImage /home/retroarch/Downloads/RetroArch-1.3.6+r444.glibc2.17-x86_64.AppImage

Ooh, that’s even better! I tried zsync already but this is even more convenient. Keeping RetroArch up-to-date is gonna be so painless (for the user at least) now.

Thank you guys for the appimages. Saves loads of time, indeed! Especially with delt’updating. Cheers.

Fails to open at all even i after i chmod os… (chmod a+x). it needs work . this is a crappy build. and are you use deb or tar.gz to build. Using ParrotSec OS (Pentesting OS)as my main driver

Hi Tux!

What’s the console output when you run the RetroArch AppImage? I used the tar.gz source to build my version of RetroArch. Have you tried the latest version of RetroArch AppImage from probono?

no but none of your other builds would work except for one that is 7.1mb in size.

Could Not Open Display "Home/user/Downloads/RetroArch-1.3.6+r444.glibc2.17-x86_64

There is no Application installed for executable file. Do you wan to search for an application to open this file?

i got that file from that site that you posted. shitty builds. Not Mediafire. i make a video and show it to you…

Keep it civil, please.