RetroArch crashing when I try to start it

I just recently started using RA and I’m completely loving the experience. I’ve set up RA on 4 or 5 machines so far and it has been going very well but last night I tried to install it on an older laptop I have and it crashes every time at launch. It is a Dell Inspiron 1525 with a Intel Core 2 Duo T8300 and 4GB or RAM and running Windows 10 Pro Insider Preview build 14279. I’m trying to run the latest stable build. I’ve tried both x86 and 64 bit versions along with the 1.3.0 version and they all crash right away. I went to event viewer in Windows and got this error Which from the look of it doesn’t really offer any information that is usable to me. If anyone might know what the issue is I’d appreciate any help I can get with it.

It’s probably an issue with the older Intel IGP/GPU. Try opening your retroarch.cfg and setting the menu_driver to “rgui” instead of “xmb”.

Thanks for answering my question but unfortunately that didn’t fix the issue.

oh, with Win10, you need to run the directx web installer. Have you done that?

I think so I know I can play SNES games with SNES9X and I believe that forces you to install it. I’m at school but I’ll check when I get home later.

Even if you’ve installed it/something before, try this one:

Make a text file in the same directory as retroarch.exe with the following line and save it as retroarch.bat, then run that batch file and reproduce the problem.

retroarch.exe -v --menu > output.log 2>&1

This will create an output.log text file with all the retroarch log messages in it. Then, open the newly-created output.log file in any text editor like Notepad and paste the contents on pastebin. Paste the link to your pastebin paste here. This will allow us to see what happened.

@hunterk I ran the Direct X but I already had it installed. @Lex I pasted the log to pastebin it can be seen here

I’m having the same issue except I’m on windows 8 and I have an intel E7500 cpu (2.97 GHz) and Intel G33/Q33/Q35 chipset with 256 mb of vram. I have tried to do xmb to rgui still crash. My output:

[QUOTE=Multikill;36973]I’m having the same issue except I’m on windows 8 and I have an intel E7500 cpu (2.97 GHz) and Intel G33/Q33/Q35 chipset with 256 mb of vram. I have tried to do xmb to rgui still crash. My output:[/QUOTE]

RetroArch [INFO] :: [GL]: Vendor: Microsoft Corporation, Renderer: GDI Generic. RetroArch [INFO] :: [GL]: Version: 1.1.0.

If your log shows ‘GDI Generic’, it means that it could not find a ‘real’ GL driver for your videocard and instead it defaulted back to a Microsoft provided software-only GL driver. I don’t even think RetroArch can work with this, and even if it would,it would be painfully slow anyway and not worth the trouble.

Update your drivers I guess and make sure they have a real GL driver that comes with them.

I went into device manager and tried to update my display adapters drivers but it says I have the latest ones. I tried to install them manually from a list but I see the one I already have plus another generic one that reproduces the same error and the same log results. So I guess that I’m SOL on this PC. It turns out that there are system requirements. Originally this was a 32 bit Vista PC that is now running 64 bit Windows 10 and Dell didn’t even support the upgrade to Windows 8 let alone 10 so there aren’t really an official drivers for the PC that I can use.

Did you check Intel’s website for drivers? They may have 64-bit drivers for your machine.

What if I use an old gpu like nvidia 8400 gs? It has support for opengl 2.1

that should work better, yeah, as long as it has a proper driver available.

Okay thanks

Just as a follow up here I just updated one of my tablets to RA 1.4.1 and now it is crashing too. This led me investigate the matter further and on this older laptop changing both the menu driver and the video driver fix the issue for me on the laptop haven’t tried on the tablet yet but it was funny it was working with 1.3.2 no issues but it crashes with 1.4.1.

Use MSVC build, msys2 builds are not working currently with intel hd 3000. You can download MSVC build from the link given in a comment from a github issue. here is the link of that issue

Okay thank you I got it to work by switching to rgui menu and d3d graphics so hopefully there will be a fix in the MSVC build as I honestly don’t know what the difference is but its good to know there are issues with the HD3000 graphics so I’m not going crazy.

Did u try this MSVC build given by’s working fine with XMB menu and gl can download it from the link below.copy it in retroarch 1.4.1 x86 build folder.

I’m using the 64 bit build will that effect using that file