Retroarch MAME: CPS-3 does not record CD game to HDD

Dear friends, I would like to know how I get Retroarch to burn CPS-3 game data to CD to HD on first boot. When starting the game, it enters the boot screen and starts transferring data from CD to HD. Until then, so good. The problem starts when I try to play the game again. He again enters the boot screen to perform a new transfer to HD. Retroarch does not save this data and this is quite annoying as I have to wait about 15 minutes for the game to start at each startup. I’m using the current MAME core.

I had no idea, I have never loaded a CD, only SF3 game and use the ROM with “NO CD” brand.

To verify it I just tested and it worked correctly, after the first charge, restart and the game starts directly.

Inside the “saves” folder, in mame/nvram, MAME creates the corresponding files, verifies that you have that well-configured folder and have write permission.

Some tricks to load the fast CD. In the core options, place the CPU in 150 and tighten the space bar, it will run very fast. After loading, place the normal CPU and save a state, so you do not have to reload everything.

Using MAME current, it seems to work properly on my side. My 2 cents : you got a privilege issue preventing the core from saving whatever it needs. Maybe the issue will disappear if you run it as admin ?

Other solution : use FBNeo which use a different romset and doesn’t require that “installation to HDD” step.

1 Like

2 posts were merged into an existing topic: How can i create a new topic? :confused:

I use Retroarch’s MAME core. Retroach does not save the game installation in the retroarch/saves/mame/nvram folder Retroach just saves the dipwitch.

Did you try my suggestion to execute it as admin ? From what i can tell, the simmX.X files in retroarch/saves/mame/nvram are created at boot, even before you install anything, if they don’t appear on your setup then i can only think of some kind of privilege issue.

Then, in the browser sees the saves folder, with right click on properties, give read and write permission. Or change the route from the folder in Retroarch, for one that you have created.

Either way, verify it is well installed, I imagine it is Windows, when installed or executes you asks administrative permissions?

I imagine this is Window (and I forgot how that creature works), if you run retroarch in administrator to save the saves of MAME, you will need to run executing always in administrator for all other cores. :thinking:

No. I don’t have problems with admin account in Retroarch folders. Retroach records dipswitches normally. I have the official MAME (Arcade64) and it saves CD data to HDD normally on first boot. After that, I don’t need to do the process again. It only happens on Retroarch. I think it’s some quick menu setting. On the other hand, I managed to work around the problem: after running the game, I wait for the entire installation process. Once installed, I pressed and saved the game. When I go to play again, I run the game and when it enters the boot screen to write to CD, I hit again and load the saved game. Okay, I no longer need to wait for the recording process. This method is not ideal. I believe there is some configuration that allows recording in the nvram folder as it happens in MAME (Arcade 64).

:thinking:

Of course! it works perfect for me and BarbuDreadMon as well. The problem has you, Retroarch can not write on that folder. Maybe you changed some parameters?

Probably some setting lost in the depth of MAME OSD, good luck finding it. I’m kinda biased about it since i’m one of its devs, but imho you would be far better switching to FBNeo, you would even get full support for most libretro features (runahead, retroachievements, …) as a side-effect

I managed to solve the problem. I found that mame.ini file was not set up correctly. So I deleted the entire ini file, loaded the game, pressed F1 to enter the quick menu and activated -boot osd- to enter the MAME menu within Retroarch. I saved a new ini configuration in the MAME menu. Now Retroarch is burning the game CD to CPS-3 memory, just like the original arcade. Thanks, even so, for everyone’s help. The administrator can close the topic.

1 Like

The question here is that there had a problem with MAME, luckily he resolved it. FBNeo is very striking and has certain advantages, although I understand that MAME emulates many more games.

Indeed, and that’s not gonna change since we are a way smaller team who prefer focusing on games we like.