RetroArch - Native CRT Support


#383

Indeed Intel and NVIDIA dont work (apart older NVIDIA model) For your information, ATI r7 to r9 work quite well, They allow to play ps2/gc/Wii and 3d arcade titles without problem. So you dont need to stick with very old GPU like 4xxx or 5xxx. I personally have a 20€ r7 240 coupled with umsa, but VGA to scart should work. If you use a DVI/hdmi only graphic card, make sure it’s dvi-i and but a DVI to VGA adapter.


#384

Hello, may i ask you how you got your picture lined up so perfectly? I installed CRT-Emudriver on my HD6450 windows system + installed the resolution list via VMM but my picture is not in the center on my Philips consumer CRT. (Also my SNES games show some weird flickering when scrolling horizontally)

Thanks in advance.


#385

Hey, thanks for the input. I read it too late sadly and already got me an old optiplex + HD6450 for cheap lol. Id love to use PCSX2 but sadly there is no core implementation and i like using a frontend to navigate my “console emulation pc”


#386

@Yuke too bad, but enjoy anyway :slightly_smiling_face:

I was wondering if someone could help me this time with linux setup. As I understand that the linux version is really easier regarding the modelines, I installed a ubuntu distro. On the LCD screen, no problems : Retroarch works. But my poor CRT TV can’t display anything (I see the red background but too much flickering, even setting this display to 640x480), I don’t manage to tell retroarch to display on this display. Any advice ?

thanks


#387

if you click the little icon in the bottom-left of the screen to bring up the applications list and search for ‘settings’ it should bring up the control panels where you can set some display stuff, like primary display, duplicate/extend, etc.


#388

thank you !

I just managed to get a 15 khz display with a xrandr command line; but avec if I take retroarch to the crt in windowed mode, it switches to the lcd when I type F to get fullscreen…


#389

Did you change the monitor index in settings > video?


#390

Yep, whatever the index is, it sticks to the LCD screen. And if I try to tell Ubuntu to display only on the second screen, it breaks the xrandr setting, and I get a divided deformed screen


#391

Hmm, that sucks :confused:

Not sure what’s going on…


#392

maybe I miss something setting up ubuntu… I just installed ubuntu, installed retroarch and that’s all. Maybe there is something to do with xrandr…


#393

Type xrandr in terminal. What is the video ID for the CRT connection?

Swap the outputs with the CRT LCD!

Currently RA only switched a few IDs I’m trying to incorporate more. But tgere is no menu item for it yet.


#394

Hello, i installed CRT Emu Driver and the resolution list via VMM. When i change Retroarch to “CRT resolution switch” the menu is squeezed together (and i cant change it back now because cant read anything anymore)

Dont know if im missing something and could need some help.


#395

This means the resolution is not changing. You need to make sure you CRT is set as the primary display.

Open the Retroarch.cfg in notepad press and hold ctlr + f. Then type crt to search. Change crt_switch_resolution to 0. crt_switch_resolution = 0 this will turn off switch off. or change it to false if you are using p[re 1.7.5

What resolutions and hz gave you installed? Have you installed them in static mode?


#396

Hello, funny thing is i tried to change it in the configfile but it didnt work. Probably forgot to save it or something…anyways i can read the menu again.

I didnt install it in static mode, dynamic was default in VMM i think and i didnt touch it.

The super.ini file from Calamity installed me like 15 resolutions i think from 2560:240 up to 800 i think…i added 320x240 under Desktop for later. Dont know if this could be the issue tho…

Where can i check if my CRT is the primary display? I didnt do multi monitor setup, just unplugged the vga cable and plugged it into my UMSA after i started EDID Emulation.

Thanks for the help


#397

It will be because you don’t have the correct resolutions installed. you need to install them in static mode and you’ll need this list at minimum:-

2560 x 192 @ 60.000000

2560 x 200 @ 60.000000

2560 x 240 @ 60.000000

2560 x 224 @ 60.000000

2560 x 237 @ 60.000000

2560 x 256 @ 50.000000

2560 x 254 @ 55.000000

2560 x 448 @ 60.000000

2560 x 480 @ 60.000000

have a look here https://github.com/libretro/RetroArch scroll down and you will see a list of resolutions.


#398

Ok, thanks. I have the User_modes.ini and the User_modes - super.ini … does it matter where i add them?


#399

you can create your own if you want just add the ones I’ve suggested. its just a text file with the .ini extension instead of .txt.

But no it does not matter which one you change.


#400

Well, guess i suck.

My file looks like this:

  • Desktop

  • 640 x 480 @ 60.000000 desktop

  • 320 x 480 @ 60.000000 desktop

  • Super resolutions

  • 2560 x 192 @ 60.000000 super

  • 2560 x 200 @ 60.000000 super

  • 2560 x 224 @ 60.000000 super

  • 2560 x 237 @ 60.000000 super

  • 2560 x 240 @ 60.000000 super

  • 2560 x 248 @ 60.000000 super

  • 2560 x 256 @ 60.000000 super

  • 2560 x 264 @ 60.000000 super

  • 2560 x 272 @ 60.000000 super

  • 2560 x 280 @ 60.000000 super

  • 2560 x 288 @ 60.000000 super

  • 2560 x 296 @ 60.000000 super

  • 2560 x 304 @ 60.000000 super

  • 2560 x 320 @ 60.000000 super

  • 2560 x 336 @ 60.000000 super

  • 2560 x 344 @ 60.000000 super

  • 2560 x 352 @ 60.000000 super

  • 2560 x 360 @ 60.000000 super

  • 2560 x 368 @ 60.000000 super

  • 2560 x 376 @ 60.000000 super

  • 2560 x 384 @ 60.000000 super

  • 2560 x 392 @ 60.000000 super

  • 2560 x 400 @ 60.000000 super

  • 2560 x 416 @ 60.000000 super

  • 2560 x 432 @ 60.000000 super

  • 2560 x 448 @ 60.000000 super

  • 2560 x 464 @ 60.000000 super

  • 2560 x 480 @ 60.000000 super

  • 2560 x 496 @ 60.000000 super

  • 2560 x 512 @ 59.000000 super

  • 2560 x 544 @ 55.000000 super

  • 2560 x 560 @ 54.000000 super

  • 2560 x 768 @ 60.000000 super

  • 2560 x 800 @ 60.000000 super

  • 2560 x 192 @ 50.000000 super

  • 2560 x 200 @ 50.000000 super

  • 2560 x 224 @ 50.000000 super

  • 2560 x 240 @ 50.000000 super

  • 2560 x 288 @ 50.000000 super

  • 2560 x 237 @ 50.000000 super

  • 2560 x 254 @ 55.000000 super

  • 2560 x 448 @ 50.000000 super

  • 2560 x 480 @ 50.000000 super

  • 2560 x 512 @ 50.000000 super

  • 2560 x 576 @ 50.000000 super

I installed them in static mode this time.

But when i started RetroArch with crt_switch_resolution = 0, my CRT went blank

When i set crt_switch_resolution = 1 its squeezed again.

Maybe i failed when dealing with the first two steps…is it normal that the 640x480 resolution, after enabling EDID emulation, feels like 30hz?

This is what i get when i start VMM:


#401

Hello Yuke, did you try to follow my tutorial (posted in this thread) ?


#402

Hi @Alphanu If I well understood, the output is VGA-0 I tried to use VGA only, not dual display. I managed to keep xrandr loading at startup in 640x480 15khz, so I Can use the crt TV only. I launch retroarch but it doesn’t change the resolution, e.g bsnes keeps launching at 640x480