RetroArch - Native CRT Support


#403

Hello, i used this guide:

http://geedorah.com/eiusdemmodi/forum/viewtopic.php?pid=1052#p1052

But ignored the groovyMAME step as i dont want an arcade machine.


#404

Ok, so if it can help, here is my step by step with files to download :


#405

Hey, thanks for the Tut. What does W7 mean? Ill try out your Resolutionlist later but dont see many differences besides the suffix “super” in my list (dunno if thats a problem) thats missing in yours. I dont need a special version of RA right? I just got me the latest x64 version. My 5:4 LED Screen im using to set everything up until i start EDID emulation is capable of 15khz, so it doesnt goes blank after activating it, thats not a problem right?


#406

W7= Windows 7. No special version of RA needed and no, your screen is not the problem but make sure the modelines and arcadeosd resolution are applied to your CRT and not your LCD.


#407

Ah, right, could have guessed it…im using windows10 tho. Should work too according to the guide.

I tried your list and as expected have exactly the same issue as with mine. So thats not the root of my problem…

Im running out of options here to be honest, no idea whats going on…After installing the Modelines i can see all the resolutions under displayadapter in windows and can switch to the resolutions to test … 320 x 240 no issue, 640 x 480 obviously working too but it hurts my eyes - feels like 30hz lol. And i can also switch to a Super Resolution…which is obviously squeezed. So i guess they are indeed installed? I tried reinstalling RA. It started up without an issue in “windowed mode”. When i go full screen my CRT went blank again…when i change to CRT Resolution Switching its squeezed again…

One thing that i observed is that after i activate EDID for “Display 1” and then switch my VGA cable into my UMSA. The window suddenly changes to “Display 4” … when i reboot its “Display 1” again. I obviously tried installing the modelines for both cases (before and after rebooting) but the result is exactly the same.


#408

Did tout try to use integer Scale ON with crt switchres 2560 activated ?


#409

Im pretty sure i did but to be sure i just did it again and it is still squeezed.

Here is my Retroarch.cfg…maybe someone can see a problem …

https://drive.google.com/open?id=16jXD2hqJync2JWtApR4C-m8DxiQWmQlg


#410

Ok so firstly you’ll want video_driver to be RGUI.

Can you upload a print screen of arcadeOSD?


#411

Sure thing.


#412

Can you post a screenshot of it when rgui (menu) is displayed?

Can you also try to toggle integer scale ON and OFF, I remember that causing a squashed screen (when it is either on or off, can’t remember which) for some emulator cores.


#413

Nevermind i think you mean Menu Driver? This is set to RGUI already.


#414

Not sure if i understand. I should start Retroarch GUI and then somehow also start arcadeOSD?

Integerscaling only fixed vertical squashing i had in SNES games for example.


#415

You’re using a setup with both CRT and LCD connected right?

Can you confirm for us that your CRT is set to be the primary display?

Click right button on desktop -> choose display settings in menu. Click the CRT display and choose set as primary display.


#416

No, im switching between LED and CRT (plug and unplug vga cable), which is a pain in the ass to be honest, but i dont want additional problems before fixing this issue…

Im close to resetting my whole windows installation to start from scratch…everything that was suggested doesnt work :frowning:

:edit:

One thing im remembering…when i installed the CRT_Emudriver (after reboot in testmode) … i got a bluescreen which lead to a automatic reboot of my PC … I didnt think much about it because i had to reboot anyways…so dunno if this could be a problem…


#417

Ok, i give up, complete Friday and Saturday wasted on this (not to speak about the money).

I started from a clean Windows installation. Had the above mentioned bluescreen again while installing the CRT-Emudriver. Nevertheless had all my Modelines visible when i checked in windows under my video adapter resolutions. I cant make Retroarch accept the Superresolutions it seems. This is as far as i could go (FinalFastasyVI running on the leftside lol):

Im still open for suggestions of course. Specs are:

  • Windows10x64
  • Dualcore 3.2ghz CPU
  • 8Gb DDR3 ram
  • ATI Radeon HD6450 with vga, dvi and hdmi out + UMSA (Ultimate Scart Adapter)

Started installation with latest Radeon Catalyst driver installed (not the crimson thingy). I have c++ redistributable from 2010 and i have directX installed … thats it nothing else besides security updates.


#418

Well it looks like the resolution has changed. It does seem like RA has lost focus on the screen! Have you tried ALT+TAB ?


#419

Just tried, nothing changed. :confused:


#420

Is RA running in windowed/borderless fullscreen instead of exclusive?


#421

Fullscreen is set to 1 and windowed fullscreen to 0…not sure where to check exclusive.


#422

I think this might be an issue with Win 10! have you tried using DX9-10 or SDL as the video driver?