Retroarch will not launch anymore? Have i broke it?


#1

I installed Retroarch on linux Mint .It worked for a bit ,controller didn’t work initially. Then black boxes appeared where the menu icons were. Then i couldn’t find my roms. Then i uninstall and reinstalled .Now it won’t launch. Any ideas ? I am clueless…sorry


#2

black boxes means it can’t find the assets. Those may be provided by a package, depending on how you installed. Otherwise, go to settings > directory and change your assets directory to somewhere user-writeable and then re-download the assets package from the online updater.

For the controller, did it show any yellow text onscreen when you plugged the controller in (or launched RetroArch if the controller was already connected)?

What do you mean by “couldn’t find my roms”? You mean you tried to scan and none showed up? Or you tried to launch them and couldn’t see them? something else?


#3

Hello hunterk, i tried to scan for roms and none showed up. So i uninstalled and reinstalled and now it won’t launch.


#4

The scanner checks the ROMs against our databases, which are typically based on No-Intro and Redump hashes. If your ROMs don’t match those databases, the scanner won’t pick them up.

However, that doesn’t mean you can’t use them. Just ‘load content’ and find your ROM in the file browser and it should fire right up. The playlists are purely optional. I never use them, personally.


#5

i can’t launch Retroarch since i reinstalled it.The black screen comes up for a moment then nothing.Do i need to uninstall properly then reinstall.?


#6

Maybe. We won’t know unless you post a verbose log.


#7

Hi, sorry for my ignorance,how do i make a verbose log on linux mint?. Is it difficult?.


#8

launch from a command line with --menu --verbose and it will print the log to the console window. You can redirect it to a file by adding:

> log.txt

after it.


#9

it says command not found ,i’m sure i’m doing something wrong .sorry


#10

Make sure you are using an executable that’s compatible with your cpu architecture, and that the executable is, well, executable… (But it seems like it should be, if it at least shows a black screen…)

Open the terminal to access the command-line (Ctrl+Alt+T seems to work) then, in the terminal:

cd to the application directory (cd /apps/retroarch or something…)

then type ./appname --flags (./retroarch --menu --verbose)

You can then see the output.

Maybe you could try re-installing by following instructions from here : https://www.retroarch.com/index.php?page=linux-instructions if it doesnt launch…


#11

./appname --flags (./retroarch --menu --verbose) i typed that and nothing happened .This may be beyond me.Must be making a mistake somewhere. i tried loading it from the link you kindly gave me still no good.Any ideas? thanks anyway.


#12

ditch the ./

If it’s installed (i.e., if you didn’t compile it yourself), you won’t be running it from the current directory, which is what ./ means.


#13

Sorry ,nothings happening.Thanks anyway.


#14

Having RA Issues on my Note 9. I run it right after Installing it, it works fine. But after, it wont run. Just get a Black Screen, then my Device Reboots.


#15

where is the retroarch folder ,from which to get a log? there seems to be many retroarch folders?


#16

The log will be in whichever directory you’re in when you launch. You can also specify a specific path by replacing log.txt in the above example with /path/to/log.txt.


#17

Hi all, i created a log i think.Maybe that has some answers. [INFO] RetroArch 1.7.5 (Git 81bca39) [INFO] === Build ======================================= Capabilities: MMX MMXEXT SSE1 SSE2 SSE3 Built: Jan 31 2019 [INFO] Version: 1.7.5 [INFO] Git: 81bca39 [INFO] ================================================= [INFO] Environ SET_PIXEL_FORMAT: RGB565. [INFO] Version of libretro API: 1 [INFO] Compiled against API: 1 [INFO] [Audio]: Set audio input rate to: 29970.03 Hz. [INFO] [Video]: Video @ 960x720 [ERROR] Using the null video driver. RetroArch will not be visible.[INFO] [Video]: Graphics driver did not initialize an input driver. Attempting to pick a suitable driver. [INFO] [udev]: Plugged pad: Microsoft X-Box 360 pad (1118:654) on port #0. [INFO] [udev]: Pad #0 (/dev/input/event4) supports force feedback. [INFO] [udev]: Pad #0 (/dev/input/event4) supports 16 force feedback effects. [INFO] [Autoconf]: 266 profiles found. [INFO] [Joypad]: Found joypad driver: “udev”. [INFO] [SDL]: Input driver initialized. [INFO] [Video]: Found display server: null [INFO] [PulseAudio]: Requested 24576 bytes buffer, got 18432. [INFO] [Menu]: Found menu display driver: “null”. [WARN] [XMB] Asset missing: /usr/share/libretro/xmb/monochrome/png/retroarch.png [WARN] [XMB] Critical asset missing, no icons will be drawn [INFO] [LED]: LED driver = ‘null’ 0x55b1597d8c20 [INFO] [MIDI]: Initializing … [INFO] [MIDI]: Input disabled. [INFO] [MIDI]: Output disabled. [INFO] [MIDI]: Initialized “null” driver. [INFO] SRAM will not be saved. [INFO] Loading history file: [/home/sc/.config/retroarch/content_history.lpl]. [INFO] Loading history file: [/home/sc/.config/retroarch/content_favorites.lpl]. [INFO] Loading history file: [/home/sc/.config/retroarch/content_music_history.lpl]. [INFO] Loading history file: [/home/sc/.config/retroarch/content_video_history.lpl]. [INFO] Loading history file: [/home/sc/.config/retroarch/content_image_history.lpl]. [INFO] [PulseAudio]: Unpausing. [INFO] [PulseAudio]: Pausing. [INFO] [autoconf]: selected configuration: /home/sc/.config/retroarch/autoconfig/udev/Microsoft X-Box 360 pad.cfg


#18

You need to either delete your ~/.config/retroarch/retroarch.cfg or open in a text editor and change your video_driver to “gl”


#19

Thank you , i have the menu again .Lets see if i can get a game going.:grinning:


#20

I can get a game to run but the sound is breaking up.Is there anything i can do.Thanks for all your help.I am running Shadow of the empire .i tried mupen64 and the other 64 emulator.Is there a setting i should try.Thanks.