Run NEO GEO CD games on Retroarch (mame_libretro) via RocketLauncher

guide

#1

Being emulated by MAME, the roms need to be in CHD format.

You’ll need:

Retroarch 1.4.0 (or above) MAME core (without year tags) A NEO GEO CD game in CHD NEO GEO and NEO GEO CD Bioses:

OBS: This method will work with RocketLauncher, its Retroarch module handles all needed commands to make Retroarch load configs, the core and then the game.

Currently (in Retroarch 1.4.1) trying to load a NEO GEO CHD file directly will crash Retroarch, it doesn’t matter if you have dummy files, correct bioses, hash files, etc.

Proper for MESS (now MAME), the bios files should be placed in the same folder where are CHDs, if the bios are put in other location, Retroarch may crash.

Maybe you’ll need to open a normal MAME game using Retroarch first to change three options, they are:

Enable softlists (OFF)

Media type (cdrm)

Boot from CLI (ON)

Now you can load the game:

Even changing the options above, all other MAME systems should work without any problem.


#2

Doesn’t work. Tried with newest nightly, bios files in folder with CHD and settings according to this guide. RA crashes upon loading CHD file. Bios were from MESS 0.151.


#3

neocd works on mame_libretro, but not in other versions or mame/mess/ume.


#4

Yup, using the newest build of Mame (the one with no date)


#5

Your problem is your old bios set, try a newer bios. Retroarch also crashes if you try an older dump of, for example CPS2 roms, they’ll only work with newer dumps.


#6

Running off the bios from MAME 181 now, still crashes.

Newest set of CHD too.


#7

Just to show my setup. Bios are from Mame 0.181 set, CHD are from Mame software set 0.181. Runs standard Neo Geo fine, but crashes upon selecting CHD


#8

There’s something wrong with your bios set, compare their kb with the ones of my screen shots.


#9

I’ve tried 3 different ones now with the same results. Not sure where you sourced your bios. My friend (doesn’t have an account here yet) ran into the same issue with his setup following the guide.


#10

just, i did make dummy zip for each chd, works easier for me.

example: choutetsu brikin’ger (1996)(saurus)(jp)[!][ironclad].chd create ironclad.zip and load that, no need to play with mame settings.

you do need to have the correct neogeo.zip bios files and neocdz.zip

NOTE: my chd’s are just manually compiled from the cd’s i have


#11

Still crashes. Tried both CHD sets from mame 0.181 and creating a CHD of my own copy of Baseball Stars (only one I have currently available on hand). Tried troubleshooting with aorin1’s directions and using the same bios sets he is.

Weird thing is I used to be able to run CDI games on prior builds, but even that is broken now… And the txt log file just stops after the game is loaded, it doesn’t say what error it runs into.


#12

you should probably set the config to defaults, i have mine at defaults and it works fine with neogeo cd

also make sure that the filenames are the one that is needed or is in mame’s hash, you should have this in mame/hash. load the neocd.xml and find there the games you have and create the correct chd file name, and the correct dummy file-im not sure why other methods do not run on my system(windows) but this procedure is the easiest i am able to play neo-cd as long as you are using the updated mame_libretro.

sample game from xml:

<software name="**ironclad**">
	<description>Choutetsu Brikin'ger (Jpn)</description>
	<year>1996</year>
	<publisher>Saurus</publisher>
	<info name="alt_title" value="超鉄ブリキンガー" />
	<info name="serial" value="NGCD-220" />
	<info name="release" value="19960920" />
	<part name="cdrom" interface="neocd_cdrom">
		<diskarea name="cdrom">
			<disk name="choutetsu brikin'ger (1996)(saurus)(jp)[!][ironclad]" sha1="4d518370686853c727eb300a91c0f070c3333225"/>
		</diskarea>
	</part>
</software>

the “software name” should be the name of your dummy zip( ironclad.zip), and “disk name” is the actual name of the chd file.

to get a better log, run this from cmd(command-line), go to your retroarch folder: type this:

retroarch --verbose --menu >> log.txt > 2>&1

run your game, when RA crashes check your log.txt, and upload it here.


#13

There`s no need to follow the hash naming, I use mine according to Redump naming convention, King of Fighters 95, The (World).chd.

I updated Retroarch yesterday to 1.4.1, got the latest core and it crashed loading any MESS game, that because “Boot from CLI” was off. I recommend that you create a MAME configuration, load a normal MAME game, inside Quick Menu Options>change Boot from CLI to ON and Media Type to cdrm, save your config and see if everything works.


#14

Hey @aorin1 it’s really great that you have taken the time to write some guides :smile:

I will give this a test the enable software lists set to off, as I currently use the software lists for Android.

Can you confirm a couple of things so when I’m testing I don’t go round in circles please.

  1. By setting cli enabled and soft lists off I can directly launch CHD games of different names to MAME convention?

  2. Will I have to change these settings to run other systems each time (or use per game overrides?) as RA can tell the difference between “systems”.


#15

Hey That, glad you’re liking the guides. I believe this method won’t work for direct loading, like “load content” and the go find the chd and load it directly, this method will work fine if you use Rocket Launcher.

And for that, I’m now thinking of making tutorials for both ways, i.e., for those who use the frontend and Rocket Launcher, and for those who launch files directly via Retroarch or use a frontend that launches the games directly without a manager like RocketLauncher.

Answering the second question, you shouldn’t need to change configs to load other games that aren’t consoles, like a normal MAME zip.

My current setup works this way, I have Arcade Classics that is almost totally emulated by MAME core, except sega model 2 and 3, I also have some consoles emulated by MAME (former MESS), that are NEO GEO CD, CD-i and in the near future FM Towns Marty. All games are running fine and I don’t have to mess with any configs to play all systems, this is what we want after all, a solid setup without our intervention.

I’ll have to dig the other way a little and build up a specific tutorial for cases like yours, probably the dummy files and the hash.


#16

I tried to run NEO GEO CD using the hash, dummy and naming the CHD according to the hash file naming, naming the roms folder to neocdz, Retroarch crashes, I’m not sure why it crashes since it works fine via RocketLauncher, so it’s definitely not a MAME driver problem.

It doesn’t mean this guide is not useful, I use RocketLauncher, Hyperspin as my frontend. RocketLauncher gives Retroarch instructions on what to run and how to run it, that’s where comes the Boot from CLI. Although Retroarch is crashing in the hash and dummy method (not covered in this tutorial), if you use a frontend that is managed by RocketLauncher, NEO GEO CD and other systems emulated by MAME will run fine.

I also updated the title stating it’s focused for RocketLauncher use.

When I manage to run these systems in the most common way (directly via Retroarch) I’ll make a guide explaining how, if no one else does before.

I’d like that someone that has this system working in the hash and dummy method, to confirm that it’s working on the latest stable Retroarch build and core, so I can figure out why it’s crashing.


#17

BYeah this make more sense now you explain the RocketLauncher integration.

Well I can try again and see if I can get it going.

For direct RA setup with softlist & Launcing from Hyperspin android

I have these things set

MAME folder in RA system folder with ini+hash folder and MAME.ini(read+write config set to 1)

Neocd.ini in the ini folder with custom rompath & read/write config set to 1)

Rom folder is structured Snk Neo geo CD-> neocdz.zip & neocdz folder

Then snk Neo geo CD ->neocdz - all my CHD folders are here with CHD’s in, also the dummy zips are here. AND another neocdz folder with the Unzipped bios inside.

Same rom format as this guide(http://www.hyperspin-fe.com/forums/topic/28989-tutorial-android-atari-5200-retroarch-setup/#comment-259437)

In retroarch I have enable softlist and auto rom type set to cdrm (I think- just woke up) and I also set read and write config to on here also. All the “boot to” options are off

Forgot to say I didn’t rename the CHD files. I left them as I got them from the dome of pleasure softlist CHD set .181 or .182 (not sure which one)


#18

I don’t really want to update my core or settings to much for fear of breaking it (I don’t have easy access to the core folder on droid to replace it) I only set it up a week or so ago


#19

OK, thanks for taking the time and for the detailed post. I just need to make sure that it’s broken or not in RA 1.4.1 with the latest MAME core.


#20

heres my log running neogeo CD, using mame(181 as of buildbot release) with default settings + hash folder + dummy file(which likely needed for cd-based like neogeo,segacd,cd-i?) method - folder name, dummyfile name and actual chd filename should be based on hash.

https://hastebin.com/ixexuqiyot.tex

if you do not want the dummy files, then you disabled software list, remove hash, and set the correct media_type but still need the files to be in the right folder(neocdz as in neogeo-cd’s case) as the folder will identify what type of system is to be used on the rom. the disadvantage of having software list OFF and no hash is that you need to switch media_type everytime you switch system. you cannot play neogeo-cd and just decide to play arcade without switching first media_type.

and also, do not enabled “mame_boot_from_cli” as this messes up loading in retroarch.