.rvz and m3u in Dolphin?

Hi,

Was just wondering if the Dolphin core see support for the new .rvz file format? And allso will m3u support be added?

The recently updated dolphin core already supports rvz.

However, there is an outstanding pull request to add the rvz extension to Dolphin so Retroarch will display .rvz files.

More info:

1 Like

How are these files different from the .wad and .iso files I currently have?

Hi, More info here : https://fr.dolphin-emu.org/blog/2020/07/05/dolphin-progress-report-may-and-june-2020

1 Like

Thank for the info Mr_Jake

Hi, I have recently set up EmulationStation on my PC and have come across this exact issue. I’m not sure if I’m running the latest versions of things since I had to download my Dolphin core manually and my EmulationStation is a combination of two copies.

Is this now functional with the latest versions and if so where do I source them? To be clear I am NOT looking for ROMS.

Thanks

Hi, I don’t know for .rvz files, but m3u is now implemented (thanks to psychonic for that).

You can get the latest build here :

1 Like

I did a bit of experimenting. Retroarch will show the .RVZ files with the core loaded but it quits out as soon as I attempt to load them.

I’m using 1.9.0 of Retroarch and the Dolphin core from here https://github.com/hunterk/libretro_builds

For me .rvz file work just fine now. I got the core from the “core downloader” in retroarch.

I have just done the same and .rvz seem to be fully working in Retroarch. Now to work out how to stop two disc games showing two entries in Emulationstation.

Does anyone have M3Us working on Dolphin? Mine don’t seem to work.

I haven’t moved over to RetroArch yet. I’m waiting for dinput to support rumble.

But I have a test setup with Metal Gear, and it works just fine.

I have Metal gears 2 discs and an m3u in a 7-zip file. I use lanuchbox and it extracts the game and firers up RetroArch.

In RetroArch I have the dolphin core setup to boot the bios.

I started the game and pressed B to get to the bios menu and then swapped the disc, started disc 2 and all works as expected.

When you try starting an m3u does it start but you can’t swap disc or doesn’t it start at all?

1 Like

The game doesn’t start. The logfile show the following error:

%homepath%\AppData\Roaming\RetroArch\retroarch.exe -L %homepath%\AppData\Roaming\RetroArch\cores\dolphin_libretro.dll “D:\RetroarchROMS\Gamecube\Metal Gear Solid - The Twin Snakes (USA).m3u”

launch terminated with nonzero exit code -1073741819!

Okay so I was thinking this may be a EmulationStation problem, but I gave it a go.

A long story short try changing your quotation marks. Just copy this one " and replace the once you are using and it should work.

I replaced them in es_systems.cfg and in my m3u file. No joy. This is my Gamecube es_systems.cfg entry if it helps:

gc Nintendo GameCube D:\RetroarchROMS\Gamecube .iso .ISO .gcm .GCM .rvz .RVZ .m3u .M3U %homepath%\AppData\Roaming\RetroArch\retroarch.exe -L %homepath%\AppData\Roaming\RetroArch\cores\dolphin_libretro.dll "%ROM_RAW%" gc gc

Entries in my m3u file and my rom files are renamed with .CD1, .CD2 etc. to hide them in Emulationstation. This is the same for PS1 Metal Gear Solid, where the same m3u’s and rom files work fine with psxrearmed but not with Duckstation on my PC.

Ok, so I run it from the command prompt and I tried this. D:\Emulators\NewRetroarch\retroarch.exe -L D:\Emulators\NewRetroarch\cores\dolphin_libretro.dll “D:\00Test\Metal Gear Solid - The Twin Snakes (USA) (Disc 1).rvz”

It starts with no problems, so I renamed it to .cd1 and tried it. Retroarch crashed for my.

I added cd1 as a file extension in the dolphin_libretro.info file but it still crashed. Maybe the core uses the file extension to know what to do with the file.

So maybe if you try renaming them back to rvz and edit the m3u and try that.

If it works you can remove rvz from Gamecube es_systems.cfg and have every game use m3u instead.

I’ve got a bat file here somewhere that makes an m3u for ever file in a folder, I’ll see if I can find it for you

I tried that. they work when renamed to .rvz. Thanks

Meanwhile I tried the same thing with my PS1 MGS. It does not work renamed to .chd in Duckstation. it is possible Duckstation does not accept m3u. The same files named CD1/2 work fine on my Retropie/Raspberry Pi. [edit] Yep it boots fine under HW Beetle with .chd extensions and with .cd1/2 extensions it boots to BIOS. Windows Retroarch doesn’t like changes to the file extensions at all.

Glad to hear that it works

Here’s the bat file:

@echo off
for %%f in (*.rvz) do echo %%f> "%%~nf.m3u"

Maybe its my browser, but when I copy text from here the quotation marks go all weird, so may you’ll need to retype them. Anyway just change *.rvz to what ever file you want to make m3us for and its good to go.

I haven’t got around trying duskstation yet, and all my PS1s are still in cue/bin. But I’m almost certain that I’ve read somewhere that you can use m3us with duckstation.

Thanks for the help. I didn’t go with this solution in the end, instead I made all the rom files hidden using the hidden function in Emulationstation. That gave me the same results but with fewer files. I did think that maybe naming the files I wanted to hide with RVZ (caps) and removing the RvZ (caps) entry from es_systems.cfg would help but I discovered that Emulationstation is not actually case sensitive on Windows.

That has solved the Gamecube problem. I’ll sort the PS1/Duckstation issue another time.

[edit] This didn’t work, the filters are not saved when Emulationstation exits. In the end I created new folders for two disk games for Gamecube and PS1 and redirected the m3u files. An inelegant solution but there are no extra files. Also Duckstation seems to have fixed itself and now accepts m3u files.

1 Like

You’re welcome, I’m just glad I could help and that we got it sorted. Good to know about Duckstation, as I’m just about to set it up for the first time.