SameBoy screen problems

Has anyone else the same issues with SameBoy or is it just me? There is a white block in every game. I’ve tried already deleting retroarch completely and reinstalled it :confused:

This is how it looks on tetris:

Maybe video driver issue? Which video driver are you using in RA? (System->Drivers->Video).

I tried vulkan, gl & gl1 so far. The problem remains. What’s weird is that it’s the same problem for other games.

Weird. Maybe BIOS issue? Somehow? Are you using an original GB or GBC BIOS, or are you relying on SameBoy’s built-in BIOS?

Yeah, it’s a missing bios issue. Here is a shot using the “optional” set of boot roms.

And here is the built-in bios.

1 Like

Does this mean I screwed something up in the settings? Or in other words, what needs to be changed to return to default? Thank you so much already :upside_down_face:

1 Like

You need to check if the ROM files are there. First, do Load Core. Select the SameBoy core. Then go to Information->Core Information. There, it shows whether or not the ROM files exist or not. If not, you need to find them and put them in retroarch’s system folder.

If you already have these ROM files, but named differently (for other GB emulators), simply copy them. SameBoy needs the GB boot ROM to be dmg_boot.bin and the GBC one cgb_boot.bin.


This solved the problem :+1: This started to drive me crazy, thank you very much!

1 Like