Sid Mier's Alpha Centuri Crashes on Dosbox Pure

Try and start the Game and I get this Crash

How can I fix the Crashing?

This is a failure in Windows and can be due to many things.

The first thing to do is to search the internet for the code that appears when you press the ‘details’ button (this is useless, but it still has to be done).

The DirectX needed by the game is missing. Normally the game CD comes with it.

Missing drivers, maybe updating the graphics acceleration in Voodoo. (I’m not sure about this, the native driver works fine. I haven’t tested it, I don’t know how much it can be improved).

The game is a WinXP release, in that case you have to enable Win98 compatibility.

(or maybe, you are missing the crack).

I checked again and Seems to be a Sound Problem.

When the sound works the Game Crashes but no sound it works fine.

How on Windows 98 do I enable the compatibility?

Forget that, I got confused when translating. Compatibility is enabled for older Windows.

And do you have the latest DirectX installed?
One thing you can do is to lower the audio acceleration in properties, to have a smoother audio. I don’t remember from memory how to do it.
I’ll try this game and let you know.

Got Direct X 8 I am pretty sure.

Thanks for Checking @alexb3d

How did the Test Go @alexb3d?

Sorry for the delay. Yes, I have done hundreds of tests. This game is making me suffer and it’s not playing.

I am amazed at the gigantic and active community this game has today.

I have tried the versions, USA, SMCX (Alpha + Alien Expansion), the Planetary Pack edition and mine, SMCX in Spanish, without success. Once I made the Spanish one work perfectly, saved the configuration, then modified it thinking it was like a save, lost it, :man_facepalming:t2: haven’t made it work again. I haven’t tried the unofficial patches yet

There is a lot of information on the internet about the GOG edition, it doesn’t work for us but it’s related, because this game is very hardware sensitive, and GOG like DOSBox are emulation and has a lot of hacks. I have tried some games (Grim Fandango, Myst V) that do not recognize the processor.

When you search for the error on the internet there is a very long post from 99 (where Jeffrey Morris from FIRAXIS) solves the problems and with the official patch 4.0 it works perfectly on real hardware. It doesn’t work in our case, but it is recommended to put the patch because it solves many other problems of the game. The readme file of the update has detailed information.

Maybe @Psyraven can help us with this, for him it should be easier to find a solution. Although it seems to me that he is not here, but on reddit.

Currently in DOSBox PURE, the game gives error when pressing the play button, if you enable the ‘Simple’ option of ‘Advanced>CPU Core’ the game comes to load the game and the 3d, by modifying the other parameters the game loads longer. If you change the name to sound.dll the game works perfectly without sound.

Here is some general information about the game.

This game is one of the most important games of the PC era and one of the best of all times, I will continue trying to make it work correctly (obsessed mode).

1 Like