[SOLVED]FBNeo how to use it with RetroArch?

Hi guys,

I would like to use FinalBurn Neo on my RetroArch.

My system is an APU Ryzen 3 plus 11Vega units with OpenSuse Tumbleewed.

I compiled from the stable zip file ( but when I tried to use “make install” it looks like it doesn’t have a rule for putting the binary into a specific folder; thus I just copied it into $HOME/.config/retroarch/cores but it looks like this wasn’t the right folder.

Where should I put that binary in order to make it working with RetroArch?



You can always see which directories RetroArch is using for things by going to settings > directory. That directory is usually correct, but make sure you have a functioning core info file for it, since that’s where the “pretty” name comes from (otherwise, it’ll just appear under the filename).

Hi Hunterk,

thank you very much for your quick replay!

In OpenSuse cores are stored in /usr/lib64/libretro and are in this format: coresName_libretro.so but the binary I compiled is just fbneo. I tried to rename it properly but it didn’t work out:

[ERROR] Failed to open libretro core: "/usr/lib64/libretro/fbneo_libretro.so"
[ERROR] Error(s): /usr/lib64/libretro/fbneo_libretro.so: cannot dynamically load executable

I am pretty sure I downloaded it from the right source:

wget https://github.com/libretro/FBNeo/archive/refs/tags/v1.0.0.02.zip

Honestly I don’t know what I am doing wrong. :frowning:

Quick note: core info file is available by default.

Thanks again!

Ah, you probably compiled the standalone executable. To compile the libretro core, you need to first navigate to src/burner/libretro and then ‘make’

Those releases are arbitrary, current wip will always be the most “stable” version and the only version we (the FBNeo team) support.

You can find instructions on building the libretro core at https://github.com/libretro/FBNeo/tree/master/src/burner/libretro#readme

1 Like

Thank you guys!

Without your help I would never found it!