[solved] FBNeo Raiden (World set 1) cheats not working

I noticed, that the native FBNeo cheats for Raiden (World set 1) aren’t working.
( Quick Menu > Core Options > Cheats)

What i did:
Fresh install of RetroArch-Win64 & FBNeo core
FBNeo cheat files in SYSTEM_DIRECTORY/fbneo/cheats/
raiden.zip matching with core/datfile (clrmamepro)

I also tested with FBNeo standalone and there the cheats are working as expected.

While other games (1941.zip and mslug.zip) haven’t problems with the FBNeo cheats, raiden.zip gives me discrepancies:


[DEBUG] [Environ]: GET_VARIABLE: fbneo-cheat-2-raiden-Invincibility_PL1 = "1 - Invincibility PL1"
[libretro DEBUG] Cheat #2, option #1. action: [libretro DEBUG] Apply cheat @ 0x1215 -> 0xB. (Undo 0x0)

but the value 0x1215 should be 0x11C5 according to the cheatfile:

cheat "Invincibility PL1"
default 0
0 "Disabled"
1 "Enabled", 0, 0x11C5, 0x0B

Am i missing something?

Nevermind, i found the solution by myself.

Apparently there is also a (really outdated?) cheat.dat in the FBNeo-cheats-master.zip in addition to the ini files.
Strangely RetroArch prioritize this file over the individual ini files and so it uses values for older romsets.

Deleting the cheat.dat solved my problems.

Because it’s the main cheat file, the .ini stuff is actually deprecated.

Thank you for the answer (and for your work on FBNeo as well :slight_smile:)

But the values in the cheat.dat are wrong? -> bug?