(Solved) [tvOS] 1.8.8 crashing

TvOS 13.4.5 unc0ver. App installs and loads fine once. However, it crashes when reopened. Tried a few times and always crashes on 2nd attempt.

App works fine when in unjailbroken state

@Trebrick Did you install it from my repo, from my IPA, or from YoshiSuga’s IPA (i.e. the official one on the libretro buildbot)?

1 Like

I didn’t know your repo had an ipa? I only see iOS? But yes using the official

So you’re using the official IPA?

You can just use my repo if you’re jailbroken…

I don’t have an AppleTV to test on, so it would be great if you could give me some feedback on my repo version, like if it works at all! :wink:

1 Like

Yes the official. Sure I’ll test yours out, thanks. I just gotta find it

The Cydia repo version is what I really want to have tested… I don’t even know if the tvOS version on it works or not!


Just add that source to Cydia, install the AppleTV version, and report back… :wink:

1 Like

I’m tripping lol I don’t see it. Only the iOS one…

Wait, I’m checking… I don’t see it neither… :no_mouth:

1 Like

Ok, I managed to find the culprit… My RetroArch Cleaner was somehow making the RetroArchTV package disappear!

Could you try it now? :smile:

1 Like

Cleaned to well apparently lol yah I see it now. I’ll check it out.have to rejb first. Hey noticed you had the provenancetv app too. Any differences there? And maybe you have an idea why mupenplus works fine in provenance but has all kinds of black texture glitches in retroarch mupen?

1 Like

Yeah, thanks to you I noticed I didn’t rename the TV version of Provenance… I hope you can test that, too!

I think the glitches are because of a bad OpenGL ES 3 implementation…

I tried to compile mupen64plus with many options to re-enable it correctly, to no avail…

@jet082 was the one doing the compilation fix for iOS 64-bit before his laptop crashed, maybe he could help once he gets his computer back!

1 Like

Just weird provenance has it figured out but not retroarch. Can’t wait for jet to be back on the scene so he can help hopefully. Hey dumb question maybe but since the file is in your Cydia repo and therefor a deb file. How do I go about converting to an ipa so I can send it to my appletv. The atv equivalent to cydia(nitotv) wont load your repo

Did you try http://johan.margueritte.free.fr/repo without a “s” at http? Some package managers like to add it but my website is not configured for https…

1 Like

Yah tried no “s” think its a bit stingy in what repos can be added

Ok, I’m having quite a hard time finding the nitoTV repo structure, but it’s not too far from a Cydia repo…

Can you try to add the source again now? (And tell me if there’s some kind of error message that I could make sense of, if there is one?)

BTW, what’s your AppleTV OS version? Is it 64-bit?

1 Like

Worked like a charm! Installing retroarch now. I’ll let u know if it’s working. Running tvOS 13.4.5. Assume its 64bit

1 Like

Dang stuck on unpacking com.libretto.retroarchtv (1.8.8) EDIT:nvm just took a minute

1 Like

@Weedy_Weed_Smoker can’t say thanks enough man! App is working perfectly so far. Opened and closed several times. Seriously appreciate the work and help you and the others give in this forum… Now to some gaming. Oh and testing provenance

1 Like

Ok that’s great!

Finally someone helped me test this, so really, thanks to YOU! :smiley:

BTW I have more cores coming up to the tvOS buildbot, and all the latest versions of the ones there…

1 Like