Time Splitters 2 Gecko Codes in RA Dolphin core

Could someone explain how to add gecko codes in RA Dolphin core? In the stand alone version of Dolphin I use the following gecko codes: F6000002 80008180 00000000 00000000 441FC000 43DB8000 14000008 44200000 1400000C 43DC0000 E0000000 80000000 F6000002 80008180 3F800000 00000000 43DB8000 441FC000 1400000C 44200000 14000008 43DC0000 E0000000 80000000. With these codes, the screen is displayed without error (white frame).

had the same problem once, you have to create the files for that in standalone ,

this worked for me

If you don’t mind getting your hands dirty in text ini files, this method should work, as well: https://forums.dolphin-emu.org/Thread-noobs-guide-for-cheat-codes-android

1 Like

In stand alone version of dolphin I add gecko codes manually. I found out that my gecko codes are in docs/dolphin emulator/game settings/GTSE4F.ini <---- Time Splitters 2 game ID. In the ini file it looks like this:

  • [gecko]

  • $Fix

  • F6000002 80008180

  • 00000000 00000000

  • 441FC000 43DB8000

  • 14000008 44200000

  • 1400000C 43DC0000

  • E0000000 80000000

  • F6000002 80008180

  • 3F800000 00000000

  • 43DB8000 441FC000

  • 1400000C 44200000

  • 14000008 43DC0000

  • E0000000 80000000

  • [Gecko_Enabled]

  • $Fix

However, when I try to add it to RA dolphin settings, the game does not see this setting and still shows white borders (RA/system/dolphin-emu/Sys/gameSettings/GTSE4F.ini

I also tried the method given by @hunterk and here also the game does not see this cheats:

  • [ActionReplay]

  • $xxx1

  • 0446E504 44200000

  • 04335720 44200000

  • 0446E500 43DC0000

  • 04335724 43DC0000

  • [ActionReplay_Enabled]

  • $xxx1

Maybe I’m doing something wrong, but I don’t know what. Here is a link to the description of the problem (dolphin page), and its solution just by entering gecko codes:

If anyone has Time Splitters 2 ntsc version, I will be grateful if this code works at all on RA dolphin core.

I think the game.ini stuff needs to go into the ‘saves’ directory, under the ‘User’ file structure.

I moved the ini to save/user/gamesettings and no luck either. edit: I forgot to enable internal cheats. Now everything works. Thanks a lot for your help @hunterk

1 Like