Turn off fullscreen bilinear filtering in PCSX2

Hi everyone! Lately I’ve been playing around with RetroArch on a CRT VGA monitor, and I found I really enjoy the integer scaling feature of the application while playing in 640x480 because it makes the picture perfectly line up with the scanlines of the display.

I have bilinear filtering turned off in the “global” settings because I feel it’s really ugly at these low resolutions and it’s really not necessary with 1:1 Pixel Aspect Ratio.

However, there are some cores that seem to have fullscreen bilinear filtering baked in, such as Dolphin and PCSX2.

While Dolphin doesn’t seem to have an option to turn it off, even in the standalone version, I’ve managed to locate the option in the PCSX2 standalone. It’s called “Texture Filtering of Display” (to disable it, it must be unchecked) and it’s under Config>Video>Plugin Settings>Shader Configuration. The same option can also be found in the GSdx.ini file in the “inis” folder and it’s called “linear_present” (1 means it’s on, 0 means it’s off).

Does someone know if there is an easy way to “hack it in” in the RetroArch core (maybe with some config files) or does it require coding and updating of the emulator itself?

Thanks in advance! c:

I think you can use inis by putting them in the folder structure the core creates (I think in ‘saves’?)

Thank you for the reply!

Hmm… It seems that the only folders PCSX2 creates in “saves” are “Slot1” and “Slot2” for virtual memory cards. I tried creating an additional “inis” folder (trying to mirror pcsx2’s standalone’s own folder structure) and I put in GSdx.ini, then I also tried putting the same file directly in the folder where the “Slot” folders are located… nothing seems to work.

By contrast, Dolphin does create a folder for inis in “saves”, but I think I have no use for it as of now…

Any other suggestions…? Maybe I’m doing something wrong.