UAE core for Retroarch


#83

What’s the correct path for the roms please? Or do i have to put the roms on the root of the system folder? That sounds too messy as there are tons of other files in there.


#84

Yes. Follow the instructions here: https://github.com/libretro/libretro-uae/blob/master/README.md The names and the MD5s must be EXACTLY as stated.


#85

I have downloadet many Commodore Roms ( including AMIGA ), BUT they are IPF Files

any chance to get them working?


#86

Only if someone implements the ipf library.


#87

Does the core support crt_switch_resolution ? If yes, could you post a sample configuration ?


#88

Hi, thank you so much for making this core functional. I managed to use it on Windows with HDFs but, I have a problem.

I’m tryng to launch ransom’s HDFs (conversions from WHDLoad packages) but in PUAE seems mandatory to use a WHDLoad.hdf as primary disk, then load the game.slave file on secondary HDF, containing only the game data. But these HDFs already contain both WHDLoad executable and game data so they can be launched on their own. Infact is not possible to run them this way.

They work great in WinUAE just using them as first and only hard disk.

So, is there some way to disable the usage of a base “WHDLoad.hdf” file when passing an HDF as content ?


#89

I’ve tried, but unfortunately, it sounds like the core is not working in lowres. It works in 640x480 on my CRT screen, but as soon as I set crt_switch_resolution to 1, it should switch on a super resolution (2560x…), but it doesn’t switch at all. @DamsRoxxx, do you think it’s an issue in the core, or an issue in RetroArch ?


#90

The usage of 2 hdf is hardcoded in the core but you could write a specific uae file to launch your specific packages.

Don’t know how exactly the crt_switch_resolution should be handled.

I think this is an issue with the core that report the wrong resolution.


#91

Was there any update on CD32 games on this core? Or is it not possible to make those games work?


#92

This is driving me insane. No matter what I do, I just end up at the boot screen with the error message ‘Not a DOS disk in device DH1’.

I am running a proper .hdf of Turrican 2 with the .Slave renamed to game.Slave, all kickstarts in RA’s system dir renamed to their proper names with their md5’s checked, and those same kickstarts are placed in the Dev/Kickstart folder in WHDLoad.hdf which is also placed in RA’s system dir.

I have even tried running a custom .uae (which I shouldn’t have to anymore, right?) a thousand different ways, for example copying and later modifying your example above, @DamsRoxxx. Same results.

The core is fully updated and I’ve checked that .hdf is supported in the core info.


#93

I don’t know where the problem is. I’ve tried to enable crt_switch_resolution but no resolution switch at all. I’ve tried both native and super resolutions with no luck.

If I do the same for a genesis game / core, no problem:

[INFO] Setting refresh rate to: 60.000 Hz.
[INFO] Environ SET_GEOMETRY.
[INFO] SET_GEOMETRY: 320x224, aspect: 1.306.

But p-uae doesn’t set the geometry

[INFO] Setting refresh rate to: 50.000 Hz.
--------------------------------------------------------------------------------
----
P-UAE 2.6.1
Git Commit: 0186c1b16f7181ffa02d73e6920d3180ce457c46
Build date: Dec  1 2018 12:36:59
--------------------------------------------------------------------------------

I hope that someone will update the core to fix this issue. Because the core has not been updated since the 12th december :frowning:


#94

Just tried this core for the first time. I’ve been a bit scared seeing there’s no core documentation for it (or did I miss it ?) but I followed your indications on this thread and managed to get it to work without too much problems. Just tried Turrican so far, but it’s working good.

I’m really waiting for the possibilty to remap the keys to a gamepad (as mentionned above, Dosbox is doing quite fine for that, the same scheme would be great) to really use it now.

So far it looks promising.


#95

Try renaming the slave file to exactly game.slave without the capital S. It could be a case sensitivity issue.


#96

That ain’t it. Happens with .adfs too. Honestly at a loss. :thinking:


#97

Hey all. what are the regulations with posting rom files? I have generated a pack of hdf roms that all work straight out of the box with retroarch. Happy to share but don’t want to break any rules.


#98

https://forums.libretro.com/t/welcome-to-libretro-forums/8

Anyway, maybe Internet Archive could be a good place?


#99

Thanks, will look into it.


#100

Unless you have the legal right to distribute them (either because you own the associated copyrights or they are distributed under a permissive license), we can’t recommend you distribute them and we certainly can’t give you any advice on how/where to do so.

We don’t promote, facilitate or otherwise encourage copyright infringement here.


#101

@squizzy: out of curiosity, are you using some sort of script to generate your hdfs?


#102

Yes. I created a bash script to unpack, rename, resize, and repack with xdftool.

I had to figure out bash scripting on the fly and have no experience with this stuff, so it’s very much NOT elegant, but it worked so… :slight_smile:

Link to script